Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

User Forms - reorder fiels


Reply


7 Posts   1426 Views

Avatar
voodoochile

Community Member, 52 Posts

4 October 2010 at 3:34pm

Hi All

i have silverstripe 2.4.0 and using the user forms module v 0.3.0 all works well except i can't drag and drop to reorder the fields

can anyone help with this please?

Avatar
MarijnKampf

Community Member, 164 Posts

6 October 2010 at 3:03am

I had the same issue, which fixed itself, I think after saving the form first time.

Avatar
voodoochile

Community Member, 52 Posts

6 October 2010 at 4:55pm

Thanks for the reply,

this is interesting all of the forms on the site have been saved and published however in the cms they appear in green not in black as a saved and published page should, so they are always in a state of changed.

where in the code would i be able to change this state manually? as this may solve the problem

Avatar
Willr

Forum Moderator, 5513 Posts

6 October 2010 at 8:17pm

voodoochile - it is always green as I was too lazy to write a working isChanged function. Workflow requests are all tied to isChanged and to work that out for a normal page its quite simple but for UDF its quite complex since all the form fields could change, emails etc etc. So it just says it changed all the time so publishing the page works fine.

Drag and drop has been a dodgy area - try the latest trunk as Jean patched an IE8 issue with this last week. Also make sure you run a ?flush=all.

Avatar
voodoochile

Community Member, 52 Posts

7 October 2010 at 9:23am

Thanks Willr

my understanding of SS has increased further now, problem is solved, i downloaded the latest trunk and did flush all, but it wasnt working in ie or ff so did dev/build then flush all and now works in both browsers.
once again thanks

Avatar
eceers

Community Member, 24 Posts

7 October 2010 at 3:17pm

This most likely a silly question... is this the right place for the latest version of userforms http://svn.silverstripe.com/open/modules/userforms/trunk

I just tried exporting from there and it didn't appear to fix the reordering problem. Even after multiple ?flush=all and dev/builds so not 100% sure i'm in the right place.

Avatar
Willr

Forum Moderator, 5513 Posts

8 October 2010 at 9:23am

eceers yes it is, perhaps try deleting the combined files in assets/_combinedfiles (if any) this is usually another cause of issues.