Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

YouTubeGallery and 2.4.2


Reply

41 Posts   6240 Views

Avatar
LisaB

8 February 2011 at 2:34am Community Member, 28 Posts

Thanks very much for your help Jeramie, I am using the files you uploaded plus the thumbnail amendments and all is back to working as it was before. I wondered if you or one of the other posters could shed any light on a couple of small problems that I have had with the youtubeservice module throughout, which is that neither the pagination nor sort order ever seem to work.

If I limit the videos per page to less than the total number it just shows that number of videos, the same number as the total at the bottom of the page, and no pagination links or text.

Whatever I specify for the sort order, it never changes and I'm not sure what they are being sorted on by default.

I get the impression that this may be a YouTube thing rather than a problem with the SilverStripe module, but I'd be grateful for any further information.

Avatar
Jeramie

11 February 2011 at 4:31am Community Member, 34 Posts

Sorry I missed this. I can't say that I have noticed any issues with pagination or sorting. What build of SS are you using? I was able to change the sort order on my install on 2.4.4

Avatar
LisaB

11 February 2011 at 11:01pm Community Member, 28 Posts

Hi Jeramie, thanks for your continued help with this. I too am using SS 2.4.4. I am getting videos by playlist ID which is specific to the logged in member. In fact I have bypassed the switch statement and removed most of the cms fields so that there is no choice in this, although even if I leave the code as it was in your earlier post and just select the options I want in the back end I still get the same problems. On YouTube itself the playlists I am using all display correctly by descending date, showing the newest first. However on my SS site they display the other way, oldest to newest, whatever sort option I select, and I never get more than one page of videos in playlists that consist of more videos than the maximum number per page. I did see something in youtubeservice.php that suggests that if you sort by a field that isn't in the YouTube video information feed no more than one page can be displayed so I wonder if this is affecting the pagination, but I'm at a loss with the sort order thing. Any help greatly appreciated as ever! I will try to get infront of a computer and paste the relevant code.

Avatar
davidm2010

6 March 2011 at 10:14am Community Member, 107 Posts

OK, I have this working on one site and it works perfect. I am trying to get it to work on another using 2.4 and I get this issue:

Webpage error details

Message: 'Prototype.Browser.IE' is null or not an object
Line: 1003
Char: 2
Code: 0
URI: http://localhost/silverstripe/youtubeservice/javascript/lightwindow.js?m=1299359365

I can't figure out what is different. Any ideas?

Avatar
bettsaj

16 August 2011 at 8:25am Community Member, 46 Posts

I think i've done something very wrong with the updated files.......... Not working at all.

Can someone explain how to get this working?........ Losing the will to live

Avatar
Jeramie

19 August 2011 at 3:56am Community Member, 34 Posts

My apologies for missing everyone's emails on this. I haven't spent any time with this module in a while and will have to re-familiarize myself with it. Give me a few days to take a look and will let you all know something more in depth.

@LisaB I will see if I can figure out the pagination issues, but it may be a question for the module maintainers (Willr and crew)

@davidM2010 I would try whats mentioned in this link http://silverstripe.org/general-questions/show/16081

@Bettsaj What version of SS are you using? Where did you download the module from? The last copy that I had working I posted here http://www.silverstripe.org/all-other-modules/show/14038 That was on version 2.4.3 I believe.

Avatar
bettsaj

23 August 2011 at 8:45am (Last edited: 23 August 2011 8:50am), Community Member, 46 Posts

Hi, i'm using SS 2.4.5 and it would appear that I'm using module version 0.2. I downloaded it from the extensions page on this site. I did see the version that you've mentioned above... is that the same release as the one on the downloads page? if not, can i just upload it and perform a dev/build to overwrite or do I have to drop tables etc?

You can view the page by visiting the site and clicking the "videos" menu button. You'll see exactly what i'm getting.

www.christinafrench.com/videos

Andy

Avatar
Jeramie

23 August 2011 at 8:54am Community Member, 34 Posts

You should be able to just download it and then upload it. I would remove the old module first and then upload the one that I uploaded. It is a modified version of the module on the downloads page. I havent personally tested in on 2.4.5, only on 2.4.3 so it may need some tweaking.

I spent some time with this this weekend and I think the pagination issue mentioned by @LisaB is beyond what I can resolve. My apologies.