Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

UserForm + recaptcha ... never accepts input.


Reply

6 Posts   878 Views

Avatar
DsX

9 November 2010 at 2:55pm Community Member, 178 Posts

OK, I have a live site with a dead contact form.
Not sure whats happening here.. userforms seems to be working well and recaptcha is displaying normally.
But my (simple) form will not accept the recaptcha text entered, if you fill out the form the and submit it just refreshes the form and give you the message (please complete the spam test) as if the spam field was not filled.

you can test the form here: http://www.shoptrapdoor.com/contact-us/

Avatar
DsX

11 November 2010 at 9:02am Community Member, 178 Posts

I still have not been able to solve this, anyone got an idea?

Avatar
Martijn

11 November 2010 at 12:14pm Community Member, 271 Posts

Do you have a correct apikey set?

Avatar
DsX

11 November 2010 at 12:52pm (Last edited: 11 November 2010 12:53pm), Community Member, 178 Posts

I believe so. The recaptcha is displaying correctly if you check the page.
to be sure I have got a new pair and set them.. but no difference.

Avatar
Martijn

11 November 2010 at 1:22pm Community Member, 271 Posts

Ah, I remember. I had this issue as well when I set the field to required in the CMS... It worked after not setting it as a required field in the form setup. Can you try that?

Avatar
DsX

12 November 2010 at 5:08am Community Member, 178 Posts

so very right you are.
Thank-you.. guess I didn't try that.. rather counter intuitive.