Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Where oh where is mollom?


Reply


6 Posts   981 Views

Avatar
Pix

Community Member, 149 Posts

5 December 2010 at 2:53pm

I can't get mollom to show on the comment form for my blog posts. I originally had Math spam protection and that worked just fine and dandy. So next I decided to try recaptcha and got that mostly working, but the layout of the widget was all messed up, so I decided to try mollom but it does not show up at all. I've got in my _config.php:

Mollom::setPublicKey('enter-your-mollom-public-key');
Mollom::setPrivateKey('enter-your-mollom-private-key');
SpamProtectorManager::set_spam_protector('MollomSpamProtector');

with my keys of course, and spam protection module in place, but it just does not render. A million thanks to anyone who knows what I should look for. I'm using SilverStripe v2.4.3, thanks!!!!

Avatar
Pix

Community Member, 149 Posts

5 December 2010 at 5:55pm

p.s. I also changed my doctype to HTML5, I'm trying everything here, and mollom just does not show up! This just does not make sense, what could I be missing? Please, anyone who could know, I thought this was going to be a piece of cake and now I've spent the whole day on it :0(

thank you!!!

Avatar
Pigeon

Community Member, 243 Posts

6 December 2010 at 4:37am

are you logged in to the cms? The spam fields don't show if that is the case.

Avatar
Pix

Community Member, 149 Posts

6 December 2010 at 8:01am

Hi Pigeon,

Thanks for the reply! I am not logged into the CMS. Wow this is weird, I just can' see why it is not showing. It seems o be installed properly and I have Mollom in the Reports tab.

Avatar
Argentum Studios

Community Member, 5 Posts

8 December 2010 at 8:09pm

If I'm not mistaken, Mollom only shows up if the contents of the comment contents seem to be spam. If the contents don't trigger the Mollom designation of spam, then the poster never sees a captcha. If you check your Mollom stats, is it showing information about blocking any spam attempts?

Avatar
Pix

Community Member, 149 Posts

9 December 2010 at 8:24am

Hi Argentum Studios,

Thank you so much for your suggestions, I appreciate you taking the time to help. I think I was trying that, typing some stuff that might look like spam, and it would not show up, but I actually never hit the 'submit' button. Maybe it only shows up after you hit submit and then asks the user for the Captcha and then hit submit again. Anyway, I finally gave up and took the darn thing off after another day of messing with it and no new info from the forum here. I had better luck with reCaptcha (at least it would show up) so I put that one back and got the styling figured out.