Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

User Forms 3.0 error with Silverstripe 2.4.x


Reply

2 Posts   981 Views

Avatar
Jeramie

9 January 2011 at 9:04pm Community Member, 34 Posts

I am currently trying to install userforms for a site and I can install the module fine; but my problem comes when trying to submit the form I get an odd message that cannot figure out. I have tried this on a clean install of 2.4.2, 2.4.3, and 2.4.4 with the same error. I am on a shared hosting space on webhosting pad and have other sites running SS just fine. Would really appreciate any thoughts or ideas.

The message is

[User Error] Uncaught Exception: Object->__call(): the method 'fortemplate' does not exist on 'UserDefinedForm_EmailRecipient'
POST /contact-us/Form

Line 724 in /home/xxxxxx/public_html/sapphire/core/Object.php
Source

715             
716             default :
717                throw new Exception (
718                   "Object->__call(): extra method $method is invalid on $this->class:" . var_export($config, true)
719                );
720          }
721       } else {
722          // Please do not change the exception code number below.
723          
724          throw new Exception("Object->__call(): the method '$method' does not exist on '$this->class'", 2175);
725       }
726    }
727    
728    // -----------------------------------------------------------------------------------------------------------------
729    
730    /**

Trace

* Object->__call(forTemplate,Array)
Line 447 of ViewableData.php
* UserDefinedForm_EmailRecipient->forTemplate()
Line 447 of ViewableData.php
* ViewableData->XML_val(Subject,,1)
Line 5 of .cache.home.xxxxxx.public_html.userforms.templates.email.SubmittedFormEmail.ss
* include(/home/xxxxxx/public_html/silverstripe-cache/.cache.home.xxxxxx.public_html.userforms.templates.email.SubmittedFormEmail.ss)
Line 420 of SSViewer.php
* SSViewer->process(ViewableData_Customised)
Line 349 of Email.php
* Email->parseVariables()
Line 439 of Email.php
* Email->send()
Line 622 of UserDefinedForm.php
* UserDefinedForm_Controller->process(Array,Form,SS_HTTPRequest)
Line 300 of Form.php
* Form->httpSubmission(SS_HTTPRequest)
Line 137 of RequestHandler.php
* RequestHandler->handleRequest(SS_HTTPRequest)
Line 155 of RequestHandler.php
* RequestHandler->handleRequest(SS_HTTPRequest)
Line 147 of Controller.php
* Controller->handleRequest(SS_HTTPRequest)
Line 199 of ContentController.php
* ContentController->handleRequest(SS_HTTPRequest)
Line 67 of ModelAsController.php
* ModelAsController->handleRequest(SS_HTTPRequest)
Line 281 of Director.php
* Director::handleRequest(SS_HTTPRequest,Session)
Line 124 of Director.php
* Director::direct(/contact-us/Form)
Line 127 of main.php

Thanks in advance

Avatar
Andre

11 November 2011 at 5:30am Community Member, 126 Posts

Hi there, I got the same Problem on SS 2.4.6.

Any Ideas?