Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Advanced Workflow


Reply


4 Posts   1481 Views

Avatar
MonkeyFish

Community Member, 12 Posts

31 January 2011 at 9:30am

Tried implementing Advanced Workflow R49. Worked well apart from my security settings no longer work.

Have a group than can only save one page. All other pages are view only. This worked great beforehand. Now after installing Advanced Workflow this group can edit all pages.

I’m pretty sure I’m using it right. It appears that the Advanced Workflow module is not accounting for the Access Edit permissions on the pages.

Is there an easy fix?

I’ve tried searching the forums but haven’t found any other issues like this however the results I get back with the forums search are not very relevant. Appears the forums search engine could do with some work also.

Any help would be greatly appreciated.

Avatar
MonkeyFish

Community Member, 12 Posts

31 January 2011 at 1:35pm

Edited: 31/01/2011 1:37pm

Ok, Ive given up on this module for now and started working with CMSWorkflow instead. RC4 didnt work very well so I accuired the latest source and installed that. The calendars wouldnt pop up with the aproval process and when pressing aprove there was a "server error".

Anyway with the latest source those two errors disapeard. A couple of new ones cropped up of course :)

A space was missing from the FutureStateNavigatorItem.ss. This was an easy fix.

Did discover that the Furture Navigator feature wasnt working at all any way and as it wasnt required I commented out everything in the FutureStateNavigatorItem.ss file.

All seems well now. Time will tell :)

Avatar
Marcus

Administrator, 87 Posts

23 February 2011 at 10:49am

It was actually an easy fix - the can* checks were returning something when it should have just been returning 'null' for some states. It's fixed now if you're still looking for a solution.

Avatar
SSK

Community Member, 4 Posts

8 May 2013 at 4:53pm

Edited: 08/05/2013 10:36pm

Hi,

I'm running SS 3.05 at the moment, and I installed the advanced workflow module (after installingthe multivaluefields and quedjobs modules). However, when I added the lines

// Enable Advanced Workflow module, apply workflow to files, enable embargo/expiry (scheduled publish/unpublish)
SiteTree::add_extension('WorkflowApplicable');
File::add_extension('FileWorkflowApplicable');
SiteTree::add_extension('WorkflowEmbargoExpiryExtension');


running dev/build/ gave me the following installation error:

Warning: Missing argument 2 for Object::add_extension(), called in /.../mysite/_config.php on line 42 and defined in /...l/framework/core/Object.php on line 453

Notice: Undefined variable: extension in /.../framework/core/Object.php on line 454

Fatal error: Object::add_extension() - Can't find extension class for "" in /.../framework/core/Object.php on line 460

I found a fix, but it meant modifying the core (Object.php) at line 453:

    public static function add_extension($classOrExtension, $extension = null) {
if(func_num_args() > 1) {
$class = $classOrExtension;
} else {
$class = get_called_class();
$extension = $classOrExtension;
}


Any ideas why this occurred and if it will be fixed in a future update?