Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing a module


Go to End
Reply


13 Posts   2578 Views

Avatar
RAEL70

Community Member, 8 Posts

19 February 2011 at 11:20pm

Hi to all.

Yesterday, I have installed locally (localhost) Silverstripe 2.4.5: no problem, everything works fine.

Today, I wanted to install any module (eg, forums or blogs).

I know that the module must be placed in the root folder of SilverStripe: done.

I also know that for activate the module in the CMS must rebuild the database going to the link http://localhost/yoursite/dev/build/?flush=1

Here's my problem, the root of SilverStripe (just downloaded and installed) contains the following folders:
-cms
-assets
-mysite
-themes
-sapphire
-googlesitemaps

The folder "dev" does not exist! How can I install any form?

I use Wampserver (latest version) with Windows 7 64 bit.

I thank everyone for the responses.

Avatar
Mrfixer

Community Member, 49 Posts

20 February 2011 at 12:29am

Edited: 20/02/2011 12:39am

Hi there, dev isnt a folder, its just an instruction,

1) get your module and unzipp to your desktop

2) look at the modules folder name, you may have to alter it.. (for example ecomemmerce module folder needs to be renamed to ecommerce)

3) drag the module folder into silverstripe root.

4) and this bit is where the "dev" bit comes in, run localhost/name_of_my_silverstripe_folder_project/dev/build

obviuosly this bit "name_of_my_silverstripe_folder_project/" needs to be the name of your folder for your SS project.

This is just a basic install of a module, there is more to it, if theres a read me in the Module folder then read it and also check out the modules _config.php file for any config options that you may need toimplement

some more info here http://doc.silverstripe.org/sapphire/en/topics/modules

Avatar
RAEL70

Community Member, 8 Posts

20 February 2011 at 1:59am

Edited: 20/02/2011 1:59am

Excuse me Mrfixer but I don't understand.

Step 1: ok
Step 2: ok
Step 3: ok
Step 4: the link would: http:\\localhost\folderofsilverstripesite\dev\build ???
Doesn't work simply because these folders doesn't exists.

For example, I want installed the Forum module.
My folder root is as follow:
-cms
-assets
-googlesitemaps
-mysite
-sapphire
-themes
-forum

we suppose that my site (folder root) is called "goofy".

For the activate the Forum module, I should write: http://localhost/goofy/dev/build or http://localhost/goofy/forum/dev/build...???

In both cases, the system doesn't work.

What is the right syntax for activate the module in question?

Thanks.

Avatar
Mrfixer

Community Member, 49 Posts

20 February 2011 at 2:13am

Edited: 20/02/2011 2:33am

Your folder structure is right, there is no need for a "dev or a build" folder,

this is correct >>> http://localhost/goofy/dev/build

EDIT: Silverstripe 2.4.5 and http://silverstripe.org/assets/modules/stable/forum-0.3-r113106.tar.gz on a test install just worked fine for me

try adding this line into your mysite/_config.php file

// dev testing environment. dev or live
Director::set_environment_type("dev");

Avatar
RAEL70

Community Member, 8 Posts

20 February 2011 at 2:38am

Dear Mrfixer,

I had written "For the activate the Forum module, I should write: http://localhost/goofy/dev/build" and then "In both cases, the system doesn't work."

Now, you write "this is correct >>> http://localhost/goofy/dev/build" that is what I wrote (it doesn't work, http error 404).

What's the problem (I used several cms and never found these difficulties)???

I have downloaded your forum but the error is always same (and could not be otherwise since the syntax of this command indicate two folders that doesn't exists).

I think to change cms: I'm disappointed 'cos, for me, SilverStripe is a very good CMS.

Avatar
Mrfixer

Community Member, 49 Posts

20 February 2011 at 2:54am

Edited: 20/02/2011 2:55am

are you running a new install of WAMP, try this in your wampservers apache httpd.con file

<Directory />
Options All
AllowOverride All
</Directory>

and have this line uncommented

LoadModule rewrite_module modules/mod_rewrite.so

save file, restart wamp

Avatar
RAEL70

Community Member, 8 Posts

20 February 2011 at 3:05am

Dear Mrfixer, you're GREAT!!!

MANY MANY MANY thanks for your support!!!

Now, I'll try other modules!

You're a friend!

P.S. I must repeat the same thing every time that I install a new module?

Avatar
Mrfixer

Community Member, 49 Posts

20 February 2011 at 3:09am

Its a pleasure, For other modules just run /dev/build, no more editing of the httpd.conf file

Go to Top