Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Userform: Issue Adding Fields


Reply

5 Posts   1015 Views

Avatar
DanStephenson

10 March 2011 at 12:56pm Community Member, 115 Posts

Hello,

We are having a problem with the userform module (version 0.3.0) on SilverStripe 2.4.5.

When we install the module and set our page to be a UserDefinedForm page, all seems to be good. We can see the new tabs, add recipients, change the button text, etc.

However, when I go to create fields, I get a blank white screen (the URL of this page is /admin/EditForm). I have error reporting turned on and my site in dev mode, but still no result.

Can anyone help solve this?

Avatar
Willr

10 March 2011 at 2:01pm Forum Moderator, 5511 Posts

This issue has been covered several times, try a search and have a look around. Perhaps http://silverstripe.org/all-other-modules/show/14251#post292653 will help.

Avatar
DanStephenson

11 March 2011 at 8:46am Community Member, 115 Posts

Hi Willr,

We read that thread and still had issues. It seemed to clear up though when we renamed the folder from "userforms-v0.3.0" to "userforms".

Avatar
Willr

11 March 2011 at 1:54pm Forum Moderator, 5511 Posts

It seemed to clear up though when we renamed the folder from "userforms-v0.3.0" to "userforms".

Yes, you will need to ensure that for all of the modules as it references the JS and CSS using userforms/css not userforms-v03.0. I believe this should already be in the readme file as a warning. With the upcoming module manager in 3.0 preventing this sort of error will be much easier!

Avatar
RichardH

27 April 2012 at 1:42pm (Last edited: 27 April 2012 6:01pm), Community Member, 8 Posts

I also had the problem described at the beginning of this posting. I followed all the steps set out in the installation guide and repeated here by WillR. Eventually I discovered that in fact not all the files had been uploaded to the webserver. So I uploaded them and since then nothing about the module works at all!. I have deleted and re-loaded them a number of times; tried extracting directly to the webserver as well, but no success.

And yet the module works without a hitch on localhost. Please help me understand why this could be!

I am using Silverstripe 2.4.7 and UserForm 0.4

Postscript:

I just tried installing via uploading and unzipping the tarball - one more time. Ran through all the required steps for changing folder nam, /dev/build, etc. And suddenly this time it all works perfectly.
go figure!