Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Share This Module TROUBLE!


Reply

6 Posts   907 Views

Avatar
Pix

23 March 2011 at 6:11am (Last edited: 23 March 2011 6:12am), Community Member, 145 Posts

Every time I try to install the Share This module I get a white screen of death with:

Sorry, there was a problem with handling your request.
Visit www.silverstripe.org to download the CMS

I don't even get to rebuild the database, all I do is upload the module folder and whamo. As soon as I delete the folder, the site is back up. I've installed plenty of other modules, no problem. I've tried with this one several times and always same result, does anyone have any ideas? I'm on SilverStripe v2.4.5.

Avatar
Mo

23 March 2011 at 9:58am Community Member, 509 Posts

Hi Pix,

By "I don't even get to rebuild the database", do you mean that you run /dev/build/ and it returns this error?

If the site you are trying to install this module on is set to be a live or staged enviroment, have you tried setting it to dev to see if there is a more detailed error?

Mo

Avatar
Pix

23 March 2011 at 10:29am Community Member, 145 Posts

Hi Mo,

Thanks for the reply. Right, when I try and run /dev/build/ all I am shown is the white screen. Same thing when I just go to the site or try and login to admin, just the white screen. Then I delete the "sharethis" folder and I am OK. I have not tried setting it to dev, good idea, I'll try that and see what more I can learn.

Thanks.

Avatar
Mo

23 March 2011 at 11:44am Community Member, 509 Posts

Sounds like a conflict to me. Are you getting Silverstripe and PHP to generate logfiles?

If not, you can try setting:

error_reporting = E_ALL

and

display_errors = On

in your PHP config, that should generate an error message on your White screen of death!

Mo

Avatar
Pix

26 March 2011 at 8:11am Community Member, 145 Posts

Hi Mo,

Thanks for all the suggestions.I put display_errors to on and this is what I get on my white Screen of Death:

Notice: DataObjectDecorator::extraDBFields() is deprecated. Please use extraStatics() instead. in /sapphire/core/model/DataObjectDecorator.php on line 60

That sounds above my head, I don't want to go messing around with the core, what do you think?

Thanks!

Avatar
Mo

29 March 2011 at 8:45am Community Member, 509 Posts

Sounds like the module isn't compatible with 2.4.5. Basically, one of the classes in the module is using an old (depreciated) method to extend something.

You could do one of two things:

1. Make changes to the module yourself, if you are doing that, a good place to start is http://doc.silverstripe.org . In relation to this error do a search for 'dataobjectdecorator'. Also have a look at the stuff on there about module development.

2. Get in touch with the module developer and submit a bug report to them. If they are still maintaining it, then they may help you out.

Haven't used the module myself, so can't offer much more than that I am afraid!

Hope that is of some help :-).

Mo