Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SOLVED: EventManagement: method 'getstarttimestamp' does not exist


Reply

706 Views

Avatar
darien

6 April 2011 at 5:30pm (Last edited: 6 April 2011 5:41pm), Community Member, 3 Posts

Using the latest SilverStripe 2.4.5 and tried both the production and HEAD eventmanagement module, this error prevents accessing the detail view of a Registerable Event page.

[User Error] Uncaught Exception: Object->__call(): the method 'getstarttimestamp' does not exist on 'RegisterableDateTime'

It was suggested by someone on IRC that perhaps this function existed in an earlier version of the core, or a dependency, but no longer does. Would anyone have an idea what this function used to look like, or how to gracefully bypass this error?

SOLUTION: Download the latest EventCalendar module from github, as the production file linked from the website does not contain the required function.