Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Event Management Not Able to Add Ticket to Event


Go to End
Reply


14 Posts   2580 Views

Avatar
the_ehb

Community Member, 8 Posts

11 April 2011 at 1:50pm

Edited: 11/04/2011 2:56pm

I have the most recent version of SS, 2.4.5 with the event calendar and event management modules installed. I also have all of the dependencies for the modules installed. I am unable to assign a created ticket to an event that i created. I have followed all of the instructions and looked all over the forum and I cannot find a solution. Anyone have any ideas?

Also, with the event resources module, it does not allow me to schedule a resource once the resource has been created. Should I use a version off of the svn for all of the calendar, event management, & event resources modules?

I also get the "Sorry, there was a problem with handling your request." error when I try to access the registered event page through the calendar on the frontend.

Avatar
ajshort

Community Member, 244 Posts

11 April 2011 at 4:36pm

Hi.

You need to put your site into development mode to get the full error. See http://doc.silverstripe.org/sapphire/en/topics/debugging for instructions on how to do so.

Just off the top of my head you need to latest event calendar module from https://github.com/unclecheese/EventCalendar - one from the module page won't do.

Avatar
the_ehb

Community Member, 8 Posts

12 April 2011 at 3:02am

Okay, thanks for that info. I wasn't sure if the one you listed was stable or not like the one on the module page, that's why I hadn't installed it yet. I have downloaded and installed the updated the event_calendar module. I am now getting the following error with the site in dev mode.

[User Error] Uncaught Exception: Object->__call(): the method 'getsearchfield' does not exist on 'ManyManyPickerField'
GET /admin/EditForm/field/DateTimes/item/7/edit?SecurityID=353f91513375acd9bef87a81ffe2e03adb64a2d6&ctf[DateTimes][start]=0&ctf[DateTimes][per_page]=10&ctf[DateTimes][showall]=0&ctf[DateTimes][sort]=&ctf[DateTimes][sort_dir]=&ctf[DateTimes][search]=&ctf[DateTimes][filter]=

Line 724 in /home/content/48/5436148/html/ballharde/sapphire/core/Object.php

It kinda looks like I might need to update other modules to newer ones if available. Any Ideas?

Avatar
ajshort

Community Member, 244 Posts

12 April 2011 at 3:38am

You'll need to get https://github.com/ajshort/silverstripe-itemsetfield as well.

Avatar
the_ehb

Community Member, 8 Posts

12 April 2011 at 3:56am

Everything seems to be working great now!! Thanks for your help!!!

Avatar
Rawish

Community Member, 5 Posts

14 April 2011 at 4:12pm

I've got the same problem aswell, got my eventcalendar, evenmanagement, itemsetfield and multiform all updated to the latest versions I could find on github.
Devmode isnt giving any error messaged but I just get the message
"Server Error: Sorry, there was a problem with handling your request."

I can however link my tickets to the event when I link them in my database with SQL but can't do it trough the cms. I am also not able to view people who registered a ticket (same error) or try to implant the paypal payment option (haven't tried any other then cheque, which is working) because I'm getting the same error.

Is it possible I've got some of my configurations wrong? I'm running SS 2.4.5.

Avatar
ajshort

Community Member, 244 Posts

14 April 2011 at 4:28pm

Edited: 14/04/2011 5:09pm

You need to put your site into development mode to get the full error. See http://doc.silverstripe.org/sapphire/en/topics/debugging for instructions on how to do so.

"Server Error: Sorry, there was a problem with handling your request" is the message shown when you aren't in dev mode. If its an ajax request you will probably need to use firebug/web inspector to inspect the request that generates an error response and pull the error message from the response body.

Avatar
Wyman

Community Member, 9 Posts

13 May 2011 at 6:36am

I also have a problem very similar to this. To save you another post I've already put myself into dev mode and I have all the other modules that are required (except the paying module which is optional)....
The error I get shows up when I create a new 'registerable event' and then open this page inside the CMS. While loading the page I get a error message popup with nothing in it and then a 500 error from the ajax call in the javascript. I've attached a pic of the js error.
I've also included a pic of the two related rows in the database to show that they are indeed there, so I don't know why the ajax request cannot pick them up.

oh and I'm running SS version 2.4.1
Any ideas?

Attached Files
Go to Top