Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Subsites Creates White Screen of Death


Reply

3 Posts   735 Views

Avatar
_Vince

16 May 2011 at 5:49pm (Last edited: 16 May 2011 5:50pm), Community Member, 161 Posts

I am using 2.4.5 and I cannot install the subsites module unless I comment out most of those "Object::add_extension(..." lines in the module's _config.php file. If I don;t comment them I get the famous White Screen of Death.

What's THAT all about? I don't want to comment things because I may lose functionality or cause problems for the users down the track, but I can't find any documentation on this, except for a post from about three years ago, that basically said the same thing.

Can anybody help me? Please?

Avatar
_Vince

16 May 2011 at 6:30pm Community Member, 161 Posts

And here's the query that crashes everything

[User Error] Couldn't run query: SELECT "Subsite"."ClassName", "Subsite"."Created", "Subsite"."LastEdited", "Subsite"."Subdomain", "Subsite"."Title", "Subsite"."RedirectURL", "Subsite"."DefaultSite", "Subsite"."Theme", "Subsite"."Domain", "Subsite"."IsPublic", "Subsite"."FaviconID", "Subsite"."ID", CASE WHEN "Subsite"."ClassName" IS NOT NULL THEN "Subsite"."ClassName" ELSE 'Subsite' END AS "RecordClassName" FROM "Subsite" LEFT JOIN `Group` ON (`SubsiteID`=`Subsite`.`ID` OR `SubsiteID` = 0) LEFT JOIN `Group_Members` ON `Group_Members`.`GroupID`=`Group`.`ID` LEFT JOIN `Permission` ON `Group`.`ID`=`Permission`.`GroupID` WHERE (`Group_Members`.`MemberID` = 1 AND `Permission`.`Code` IN ('CMS_ACCESS_CMSMain', 'ADMIN') AND (Subdomain IS NOT NULL OR `Subsite`.ClassName IN ('Subsite_Template')) AND `Subsite`.Title != '') GROUP BY "Subsite"."ClassName", "Subsite"."Created", "Subsite"."LastEdited", "Subsite"."Subdomain", "Subsite"."Title", "Subsite"."RedirectURL", "Subsite"."DefaultSite", "Subsite"."Theme", "Subsite"."Domain", "Subsite"."IsPublic", "Subsite"."FaviconID", "Subsite"."ID", CASE WHEN "Subsite"."ClassName" IS NOT NULL THEN "Subsite"."ClassName" ELSE 'Subsite' END ORDER BY "Title" Unknown column 'SubsiteID' in 'on clause'

Avatar
_Vince

17 May 2011 at 8:51am Community Member, 161 Posts

Ok, I've realised that the subsites module in the "extensions" section doesn't actually work (so why is it there?) and I need the trunk version from https://github.com/silverstripe/silverstripe-subsites