Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Newsletter


Reply

8 Posts   570 Views

Avatar
pukkafish

9 June 2011 at 8:19am Community Member, 8 Posts

Hello,

First of all, I have to say that I'm new to SilverStripe.

I've managed to install it (version 2.3.3) and it was working fine.

Then I had the need to use the newsletter module.
There wasn't any install guide, and looking around, it looks like you have to put the folder (unzipped) in the sapphire directory.

Now, running the website, I have an error:

[User Error] Couldn't run query: SELECT `SiteTree`.*, `GhostPage`.*, `ErrorPage`.*, `RedirectorPage`.*, `VirtualPage`.*, `SubscriptionPage`.*, `SiteTree`.ID, if(`SiteTree`.ClassName,`SiteTree`.ClassName,'SiteTree') AS RecordClassName FROM `SiteTree` LEFT JOIN `GhostPage` ON `GhostPage`.ID = `SiteTree`.ID LEFT JOIN `ErrorPage` ON `ErrorPage`.ID = `SiteTree`.ID LEFT JOIN `RedirectorPage` ON `RedirectorPage`.ID = `SiteTree`.ID LEFT JOIN `VirtualPage` ON `VirtualPage`.ID = `SiteTree`.ID LEFT JOIN `SubscriptionPage` ON `SubscriptionPage`.ID = `SiteTree`.ID WHERE (HomepageForDomain REGEXP '(, ^) *pukkafish\.co\.uk *(,|$)') ORDER BY Sort LIMIT 1 | Table 'pukk2ou_silver.SubscriptionPage' doesn't exist
GET /projects/silver/

Line 401 in /home/pukk2ou/public_html/projects/silver/sapphire/core/model/MySQLDatabase.php

My questions are:

1- how to install a module?
2- what could be wrong?

Thanks

Avatar
pukkafish

9 June 2011 at 8:27am Community Member, 8 Posts

Ok, managed to go a bit further.

I've created two new tables: SubscriptionPage_Live and SubscriptionPage_Live with one column each called 'ID' ...

Avatar
pukkafish

9 June 2011 at 8:36am Community Member, 8 Posts

Sorted out.

Needed to rebuild the database by going to http://<url>/dev/build

Avatar
pukkafish

9 June 2011 at 8:57am Community Member, 8 Posts

Sorry, stuck again ...

Now I have a Newsletter menu.

Clicking on it, I have a message on the right pane: Welcome to the SilverStripe CMS newsletter admininistration section. Please choose a folder from the left.

On the left pane, I have Create and Delete buttons. Clicking on the Create button doesn't do anything.

Heeeeeelp !!!

Thank you

Avatar
pukkafish

9 June 2011 at 9:23am Community Member, 8 Posts

Making progress.

Installation:
1- unzip the newsletter archive
2- upload it to the root of your silverstripe
3- go to http://<url>/dev/build

That's it.

Avatar
Willr

9 June 2011 at 4:13pm Forum Moderator, 5511 Posts

I've managed to install it (version 2.3.3) and it was working fine.

Any reason for not using 2.4? 2.3.3 is *really* old. The latest newsletter module may not support a release as old as that.

Avatar
pukkafish

9 June 2011 at 8:01pm Community Member, 8 Posts

Thank you Willr.

The reason to use 2.3.3 is because my customer is using it.

I'm new to SilverStripe, and I'm not sure how the upgrade works. Maybe I should try to upgrade it first, then use the newsletter module !

Anyway, I've done some progress on it.
It seems to be installed fine.
I've created a template.

The problem I have are:

1- if I create a draft, and save it, if I go away and come back to my draft, I have a loading error.
2- I've tried to create a subscription page, but when the user register, I have an error. Also, I don't know if the subscription page comes from the newsletter module, or out of the box (silverstripe) ...

Error:

[Warning] DataObject::get_by_id passed a non-numeric ID #
POST /projects/silver/subscriptionpage/Form

Line 2566 in /home/pukk2ou/public_html/projects/silver/sapphire/core/model/DataObject.php

Avatar
Willr

9 June 2011 at 8:30pm Forum Moderator, 5511 Posts

Depending on the complexity of your clients existing site I would suggest upgrading. By using 2.3.3 you expose several well defined security holes in your site anyway so it may be worth upgrading just for that.