Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem with translatable


Reply

3 Posts   783 Views

Avatar
wachupe

14 July 2011 at 8:33am Community Member, 15 Posts

By placing the module in the SilverStripe open up the Web and then sent me this ERROR

Warning: There are two files both containing the same class: '/home1/geyceing/public_html/prueba/sapphire/tasks/MigrateTranslatableTask.php' and '/home1/geyceing/public_html/prueba/silverstripe-silverstripe-translatable-515b028/code/tasks/MigrateTranslatableTask.php'. This might mean that the wrong code is being used. in /home1/geyceing/public_html/prueba/sapphire/core/ManifestBuilder.php on line 487

Fatal error: Class 'DataExtension' not found in /home1/geyceing/public_html/prueba/silverstripe-silverstripe-translatable-515b028/code/model/Translatable.php on line 163

use silverstripe 2.4.5

Avatar
Invader_Zim

14 July 2011 at 9:12am Community Member, 141 Posts

Hi wachupe,

don't use the Translatable module with SS.2.4.5. It's meant for SS.3.0...
If you delete it, the error will be gone.

Good news is, SS.2.4.5 has Translatable already built in.
Read more about enabling it here: [url]http://doc.silverstripe.org/sapphire/en/topics/translation[/url],
and I recommend to read this amazingly fine article from SSBits:
[url]http://www.ssbits.com/tutorials/2011/using-translatable-to-create-a-simple-multilingual-site/[/url] :-)

Cheers
Christian

Avatar
wachupe

14 July 2011 at 9:57am Community Member, 15 Posts

thx for you help Invader_Zim (: