Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Compass module - using alpha/beta


Reply

4 Posts   567 Views

Avatar
Matty Balaam

24 January 2012 at 10:43pm Community Member, 69 Posts

I'm trying to use a compass add-on for css3 animations: https://github.com/ericam/compass-animation I get the following error if I try to use it:

Unable to activate animation-0.1.alpha.0, because compass-0.11.7 conflicts with compass (>= 0.12.alpha.0)

Is there a way to force the Compass module onto the latest release? I see in Compass.php there is $sass_version which I've tried to set to 'latest' but it then gives me the following error:

[User Error] Compass Error:/Library/Ruby/Site/1.8/rubygems/requirement.rb:81:in `parse': Illformed requirement [""] (ArgumentError)   from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `initialize'   from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `map!'   from /Library/Ruby/Site/1.8/rubygems/requirement.rb:106:in `initialize'   from /Library/Ruby/Site/1.8/rubygems/requirement.rb:44:in `new'   from /Library/Ruby/Site/1.8/rubygems/requirement.rb:44:in `create'   from /Library/Ruby/Site/1.8/rubygems/dependency.rb:50:in `initialize'   from /Library/Ruby/Site/1.8/rubygems.rb:303:in `new'   from /Library/Ruby/Site/1.8/rubygems.rb:303:in `bin_path'   from -e:6

Thanks.

Avatar
Willr

8 February 2012 at 9:54pm Forum Moderator, 5511 Posts

because compass-0.11.7 conflicts with compass (>= 0.12.alpha.0)

Looks like you should uninstall 0.11.7 first.

Avatar
Matty Balaam

9 February 2012 at 12:18am (Last edited: 9 February 2012 12:31am), Community Member, 69 Posts

I'm a bit confused, I was under the impression that the Compass module took care of selecting the latest gems?

Edit: Took another look and managed to get it woking by changes the code in Compass.php on line 39 to

'yard' => '', 'maruku' => '', 'haml' => '~> 3.1', 'compass' => '>= 0.12.alpha.0', 'compass-colors' => ''

I guess there must be a way of overriding this without hacking the code?

Avatar
Matty Balaam

9 February 2012 at 1:08am Community Member, 69 Posts

Actually it didn't work, it now won't compile any code. If I delete the CSS files already there they are not remade.