Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

cmsworkflow installing problem with 2.4.7

Go to End

5 Posts   819 Views


Community Member, 10 Posts

15 March 2012 at 1:55am


I'm stuck installing the cmsworkflow module for silverstripe.
I downloaded the latest version of:
- SilverStripe >> SilverStripe-v2.4.7.tar.gz
- CMSWorkflow >>
- legacydatetimefields >>

I put the two modules directly into silverstripe root folder and renamed it to cmsworkflow and legacydatetimefields.

Installed worked with /dev/build but I can't see the menu button "Roles" in the admin frontend. So I'm doubt cmsworkflow is installed correctly.

Is cmsworkflow compatible with 2.4.7? Someone else having the same problem or could give me advice how to get it running correctly?

TIA Bundschuh


Forum Moderator, 5521 Posts

15 March 2012 at 10:49pm

Roles are under the Security tab. You need to configure cmsworkflow to your needs (2 step or 3 step) I believe before you will see any obvious changes.


Community Member, 10 Posts

16 March 2012 at 10:23pm

Hello Willr,

thanks for your reply. Since I was pressed for time to get an approval workflow up and running, I decided to switch to the module 'advanced workflow'.
Maybe I was so confused by not seeing the menu point "Roles" that I assumed the module is not up to date. :)

Nevertheless, Advance Workflow works fine for me. I will stay on this one.



Community Member, 10 Posts

16 March 2012 at 10:26pm

Found this relating thread by the way.

The documetation seems to be "littlebit" out of date for over two years now. :)

Cheers Bundschuh


Community Member, 2 Posts

1 July 2013 at 11:58pm

How do I install a module on SilverStripe?