Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Non latin characters - image gallery


Reply


5 Posts   509 Views

Avatar
Gaudino

Community Member, 8 Posts

25 April 2012 at 9:22pm

Hi,

I have a little problem with image gallery module. My website is in Czech. When I want to create new photo gallery page my URL adress is not a correctly.

My photo gallery name is for example Louis Vuitton - Budapešť, Maďarsko, but Silverstripe module generate URL louis-vuitton-budapes-ma-arsko. Some non latin characters are missing in URL adress.

My Silverstripe version is 2.4.7.

Can anyone help me?

Thx Pavel

Avatar
Juanitou

Community Member, 323 Posts

25 April 2012 at 10:16pm

Hi Pavel,

The Link() function in the ImageGalleryAlbum class is created on the basis of the Folder associated with the Album, which is created in the assets folder when you create the album. So, you have to replace the name of the assets folder, i.e. louis-vuitton-budapest-madarsko.

Hope it helps,
Juan

Avatar
Gaudino

Community Member, 8 Posts

25 April 2012 at 11:13pm

Thank you for your replay Juan, but this solution dont work for me. If I rename the folder, this concrete photo gallery is missing and the URL stay louis-vuitton-budapest-madarsko.

I need some function in PHP code for it, because this web is form my client and he have not a skills to do same changes on FTP.

Any other ideas please?

Avatar
Juanitou

Community Member, 323 Posts

26 April 2012 at 12:40am

Did you rename the folder through the assets CMS interface? You could also do it directly in the File MySQL table, but you shouldn’t touch it through FTP for evident reasons!

Avatar
Gaudino

Community Member, 8 Posts

26 April 2012 at 7:30pm

Hi Juan,

I renamed the name of the folder through CMS interface and I have it:-)

Thx Pavel