Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

event_calendar not installing


Reply


2 Posts   442 Views

Avatar
kkorver

Community Member, 2 Posts

5 July 2012 at 12:20am

I tried the latest version of the event_calendar module with a fresh install of Silverstripe 2.4.7 (installed dataobject_manager and uploadify first). It wouldn't install correctly so i tried again in dev mode. When doing a dev/build i see a lot of errors about finding double classes. Not something i can resolve myself.
There is no older version of the event_calender i can get working without major errors. Is there a combination of versions(silverstripe, dataobjectmanager, event_calendar) that will work? Please let me know.

Avatar
kkorver

Community Member, 2 Posts

5 July 2012 at 7:27pm

At the moment I have the 2.4 branch from github working (with the master branch I got the error about the double classes). I have to manually fill in the dates (my locale is nl-NL) like 4-juli-2012 or i get an error about not filling in the dates correctly.
Is there a way that I don't have to fill in the dates manually??

There was also an error about "index of Calendar not known" in CalendarUtil.php when trying to look at a calendar page.
After changing line 97 in CalendarUtil.php from "$template = _t("Calendar.$key",$lang['en_US']['Calendar'][$key]);" to "$template = _t("Calendar.$key");" it seems to work, but I am not a programmer and don't really know what the consequences are for this change.