Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Sphinx module: [User Notice] Could not stop sphinx searchd


Reply


2 Posts   813 Views

Avatar
jere

Community Member, 8 Posts

10 July 2012 at 9:19am

Hi, this is my first post on this forum...

I'm upgrading a fairly large site from SS 2.4 to 2.4.7. The upgrade is on a dev server with latest ubuntu (12.04) and latest sphinx (2.0.4). I'm having real trouble getting the SS Sphinx module installed; running dev/build gets as far as creating database records for Page (which is decorated with sphinx) then throws the following error:

***
[User Notice] Could not stop sphinx searchd
GET /dev/build?flush=1
Line 348 in (path-to-root)/sphinx/code/Sphinx.php
***

Visiting /Sphinx/stop in a browser also gives the same error.

Visiting /Sphinx/reindex in a browser gives the following error:

***
ERROR

Sphinx 2.0.4-release (r3135)
Copyright (c) 2001-2012, Andrew Aksyonoff
Copyright (c) 2008-2012, Sphinx Technologies Inc (http://sphinxsearch.com)

using config file '/var/www/(root-directory)/silverstripe-cache/sphinx/sphinx.conf'...
WARNING: failed to scanf pid from pid_file '/var/www/(root-directory)/silverstripe-cache/sphinx/searchd.pid'.
indexing index 'Page'...
ERROR: index 'Page': xmlpipe: expected '<document>', got 'ERROR [User Error]: Uncaught Exception: Object->__call(): the m'.
total 0 docs, 0 bytes
total 0.001 sec, 0 bytes/sec, 0.00 docs/sec
***

and so-on for every sub-class of Page

Sphinx module is working fine on the live site, which is on an older version of ubuntu and sphinx 0.9.

I'm at a loss to figure this out. Has anyone else had experience/advice around this? I'd be really grateful for any pointers.

Avatar
jere

Community Member, 8 Posts

25 July 2012 at 11:42am

Update: I've decided to drop Sphinx entirely and go for Google Site Search instead, which seems to be a much better option; takes the load off our server for running searches and the search parameters are easy to refine and customize. Also really fast.