Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Compass module error


Reply

3 Posts   613 Views

Avatar
martimiz

14 August 2012 at 4:02am (Last edited: 14 August 2012 4:04am), Forum Moderator, 1095 Posts

Hi,

Can I use the Compass module from the browser url?

I installed it from here: https://github.com/silverstripe-labs/silverstripe-compass/, and I'm getting the following error:

Error converting /compasstest/css/test.css Error from css2sass was: /usr/lib/ruby/1.8/rubygems.rb:323:in `bin_path': can't find gem css2sass (>= 0) (Gem::GemNotFoundException) from -e:6 Conversion succesfull.

I created a module compasstest, with a _config.php and a css directory holding a single file test.css. Then I visited: mydomain/dev/compass/convert?module=compasstest

The sass directory is created, but the converted file is not. The gems are installed in silverstripe-cache/gems/, the directories are writable. I've tried installing the compass files to a different folder, manually installing them, the result is always the same.

There is no css2sass file present, as far as I can see. What am I doing wrong? is it that I can't execute this from the browser URL? Should I use sake instead? Or is it something else?

[EDIT] I tried installing sake, but no luck with Debian Squeeze yet :-( ...

Thanks, Martine

Avatar
Matty Balaam

14 August 2012 at 9:39pm Community Member, 69 Posts

I already have my files as SCSS (you can convert them with online tools: http://css2sass.heroku.com/)

But I kept getting a "Sass is in the process of being separated from Haml" error with my files.

I needed to alter the required gems array to the following to get files to compile.

'yard' => '', 'maruku' => '', 'sass' => '~> 3.2', 'compass' => '~> 0.12.2', 'compass-colors' => ''

Avatar
martimiz

15 August 2012 at 4:58am Forum Moderator, 1095 Posts

Thanks Matty, I'm happy to work with that link one for now :-) As for the rebuild from scss to css: that seems to work fine for me (using the newest from master).

I've sake working fine now - my bad for not reading the docs properly. But the error is still there, so I suppose it could either be a bug or some settings issue on my server. Maybe someone can reproduce this?

# sake dev/compass/convert --module=compasstest

Error converting /compasstest/css/test.css

Error from css2sass was:
/usr/lib/ruby/1.8/rubygems.rb:323:in `bin_path': can't find gem css2sass (>= 0) (Gem::GemNotFoundException)
   from -e:6

Conversion succesfull