Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Subsites Module on SS 3


Reply


2 Posts   626 Views

Avatar
gaethofs

Community Member, 9 Posts

3 September 2012 at 5:03am

Hi!
I just started working with SS 3 and I'm trying to get all my modules working.
Subsites isn't working right now.
It's SS 3.01 freshly installed on a clean server,
and the latest build from subsites (from github).

I encountered a few problems when I was installing SS3.
The first problem I had was with a fatal error on mcrypt_create_iv(64,1),
I removed the function and used the older ones to fall back.

After reinstalling, it worked and I could perform all the possible actions.
The subsites module installed without a problem,
and after adding new subsites and adding their domains,
I bumped against another problem.

The subsites were visible in the admin panel but when I was no longer able to add a new page
in any of the sites, not even in the main site I had before installing the module.

I increased all possible memory limits, but still, no change.

Anyone encountered the same problem and got it working?

Avatar
webdiv

Community Member, 1 Post

16 September 2012 at 8:29am

Same thing for me. I've been desperately waiting for subsites for 3.x to be released for months now. It was down in the roadmap as being something that would be released with 3.0 but was not. Now you can search and download the extension for 3.x but it is not functional. The best that can be said for it is that adding this extension will not crash your install like some of the other 3.x modules.

I have two different projects now that were needing subsites that are in a holding pattern. It's a little frustrating for it to be offered as a download in its current form- it does not work.

Yes I know I should be fixing the problem instead of whining. :) I've put my rep on the line getting people on board to use SilverStripe, but 3.x modules still have so many issues that I feel like we should have gone 2.x instead.