Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Flexslider Module for ss3


Go to End
Reply


20 Posts   3420 Views

Avatar
lx

Community Member, 83 Posts

9 October 2012 at 9:31am

I just added a slider Module for ss3.
It uses the flexslider JavaScript Library.
The created sliders are responsive and Support slide gestures on mobile devices.

You can Download the Module here:
https://github.com/lx-berlin/silverstripe-flexslider

The Module was just released , so there might still be Bugs in it.
If you find One, please Report on github or in this Forum thread.

Avatar
lx

Community Member, 83 Posts

10 October 2012 at 5:21am

I just added a detailed documentation which mainly consists of screenshots.
http://www.netefx.de/Silverstripe-flexslider.php

The documentation is not yet finished but if gives you an idea how the slider looks like.

Avatar
Liam

Community Member, 470 Posts

11 October 2012 at 3:30am

I'll be sure to keep an eye on it as I use Flexslider for all my sliders.

From what I briefly saw, looks good. Thanks!

Avatar
tiatisch85

Community Member, 5 Posts

30 October 2012 at 8:44am

Thank you lx for the great modul.

When using the "simple" themes must be the jQuery integration in page.ss still be deleted. Otherwise there will be conflicts.

Avatar
nmshah

Community Member, 21 Posts

28 January 2013 at 7:33pm

I have added the module to my website and followed the tutorial as mentioned on the mentioned site. It all seems to work fine at the backend but nothing is being displayed on the Home page.

Both in the templates and shortcode method to display the slider, in the source code, the flexslider content is present but it is not being displayed.

Kindly check out the following link: http://inspiredsolutions.in

Have added the code in templates just above the title of the page.

Kindly help

Avatar
lx

Community Member, 83 Posts

28 January 2013 at 11:42pm

Edited: 28/01/2013 11:42pm

Hi nmshah,

looks again like a jQuery problem.
If you open the firebug console you will see this message:

TypeError: $ is not a function

$('.flexslider_1').flexslider({

I am wondering why there is a form on this website before the opening <html> tag. Is this also caused by the flexslider plugin ?

But before i checked your website on my pc i did check it on my ipad. And guess what, the flexslider was working perfectly on the ipad. I could move the 2 slides "inspiRed" and "experimental Marketing".

Maybe you should check your template again.
Or maybe you require jQuery yourself and remove the requirement in the module.

Avatar
nmshah

Community Member, 21 Posts

29 January 2013 at 9:54am

Hello Lx,

Thank you
I have got the slider working now by removing the jquery requirement from the module.

As for the contact form before html, that is something that I have been trying to resolve but have been getting stuck.

I am trying to include a php contact form in the website using the following code in page.php

   public function MyContactForm() {
      $contact_form_path = '/home/insol/public_html/contact-files/'; // set path to /contact-files/ with slash on end.
      require $contact_form_path . 'contact-form-run.php';
      $contact_form = '1'; // set desired form number.
   }

Have no idea what to do? Any suggestions would be greatly helpful...

Avatar
nmshah

Community Member, 21 Posts

30 January 2013 at 11:34pm

It worked initially but then suddenly I had the same problem.
This time I hope I have solved it for good by

Changing Line 2 on /flexslider/javascript/flexslider.template.js

From

$('.flexslider_$sliderID').flexslider({


to

jQuery('.flexslider_$sliderID').flexslider({

Go to Top