Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

googlesitemaps for SS 3.0


Reply

3 Posts   432 Views

Avatar
dacar

6 November 2012 at 11:38am Community Member, 168 Posts

Hi, i am just testing the googlesitemaps module for SS 3.2. There is a problem to get a valid .xml because of the $Priority. in my sitemap.xml $Priority is not correctely formated as a float: <priority>0,9</priority>.

In my _config.php i have set: setlocale (LC_ALL, 'de_DE@euro', 'de_DE.UTF-8', 'de_DE', 'de', 'ge');

Is there a way to set setlocale(LC_NUMERIC, 'en_US') just for the sitemap.xml?

Also ther is an error in GoogleSitemap.ss instead of <% if $ChangeFreq %><changefreq>$ChangeFreq</changefreq><% end_if %> it should be: <% if $getChangeFrequency %><changefreq>$getChangeFrequency</changefreq><% end_if %>.

Hope, that someone can help.

Greetings, Carsten.

Avatar
Juanitou

7 November 2012 at 1:04am Community Member, 323 Posts

Hi Carsten.

May I suggest you to open a ticket in GitHub?
https://github.com/silverstripe-labs/silverstripe-googlesitemaps/issues

I think it’s the better way to get these issues resolved.

Best regards,
Juan

Avatar
dacar

7 November 2012 at 4:16am Community Member, 168 Posts

Hi Juanitou,

you are right. I have opened to tickets at [url]https://github.com/silverstripe-labs/silverstripe-googlesitemaps/issues/27[/url] and [url]https://github.com/silverstripe-labs/silverstripe-googlesitemaps/issues/26[/url]

Greetings, Carsten.