Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

DMS not working


Reply

7 Posts   708 Views

Avatar
Lexandclo

28 November 2012 at 9:22am Community Member, 34 Posts

Hi All

ive tried installing the new DMS Mod, but get a 500 internal server error when i try to load a page in the cms area.

i drop the folder in root.
dev/build (t builds databases)
site loads fine
put the site in dev mode no errors

still no joy

Any ideas
thanks

Darren

Avatar
Lexandclo

30 November 2012 at 8:52am Community Member, 34 Posts

I love silverstripe and have for the past 3-4 years, but the one thing that lets it down is the lack of community help.

some times members can wait over 3 months for a response from any one.
moan over.

bet its 2-3 days before someone comments

Avatar
the-tech-guy

17 February 2014 at 4:16pm Community Member, 13 Posts

Bump!

Anyone have an update on this?

I have also tried to install the DMS module into my companies website for some basic document management and I have the same problem,

I have copied the folder into the home directory, renamed it to "dms", emptied the cache and rebuilt the database but I can't access the backed, I too get the same problem "internal server error", is there something that I am missing?

Avatar
Willr

17 February 2014 at 5:49pm Forum Moderator, 5511 Posts

Please read the FAQ before posting. A 500 internal server error is a generic error, check your error logs for the actual error message or turn on dev mode. One thing I would check from experience is make sure the dms-assets folder (where DMS assets are stored) is writable by the web server.

Avatar
the-tech-guy

17 February 2014 at 6:57pm Community Member, 13 Posts

Hey Willr,

I actually didn't know that the DMS had a FAQ or I would have read it first, my apologies.

No when you say check that the folder is writeable, you are talking about setting permissions of the folder eg "7-5-5"

Thanks for the idea's I will try turning on dev mode.

Avatar
Willr

17 February 2014 at 7:14pm Forum Moderator, 5511 Posts

Sorry, I was referring to the forum FAQ which covers the (not helpful) internal server error http://www.silverstripe.org/general-questions/show/16055.

Avatar
BigMoose

12 March 2014 at 6:49am Community Member, 19 Posts

Hi, I was having the exact same headache for the better part of a week, but solved it for myself. One of the requirements for the DMS module to work is to also install the 'Grid Field Extensions' module:
http://addons.silverstripe.org/add-ons/ajshort/silverstripe-gridfieldextensions

This news is unfortunately very difficult to find as it makes no mention of this in the readme file, or anywhere on Github from what I can see. It only mentions: "PHP 5.3 with the "fileinfo" module (or alternatively the "whereis" and "file" Unix commands)"

I just happened to come across the other requirement at the very bottom of:
http://addons.silverstripe.org/add-ons/silverstripe/dms

Under 'Versions'.

I hope this works for you. Poor documentation and unhelpful responses make learning SilverStripe needlessly difficult.