Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

ReCaptcha doens't accept validation code


Reply


440 Views

Avatar
s_a_m_y

Community Member, 25 Posts

28 January 2013 at 3:26am

Edited: 28/01/2013 3:28am

Hi to all,

I have had some SPAM-issues lately and decided to install a Captcha-Module. According to the installation-guide I first installed the Spam Protection Module, ran a /dev/build and then placed the ReCaptcha Module and added the following lines to my _config.php:

// Spam Protection Module
SpamProtectorManager::set_spam_protector("RecaptchaProtector");

// Recaptcha
RecaptchaField::$public_api_key = 'publickeyhere';
RecaptchaField::$private_api_key = 'privatekeyhere';

I was a little confused because the installation note for the Spam Protector said to include:

SpamProtectorManager::set_spam_protector('MollomSpamProtector');

However, after a flush I could add a Spam Protection Field and the Captcha was correctly displayed on the page. I additionally changed the theme:

RecaptchaField::$js_options = array('theme' => 'clean');

All looked fine. However, when I tested the form and entered the validation code it won't go through. The custom error message keeps being displayed and no email is send.
I have no clue what's happening and I haven't found any hints in the forum or online otherwise. I am grateful for any idea!

Thanks. Sam

P.S. This project is still running on 2.4...