Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Image Gallery Extension: Testers Needed


Go to End
Reply


417 Posts   80929 Views

Avatar
UncleCheese

Forum Moderator, 4096 Posts

8 March 2009 at 12:42pm

Was it working before you did the update?

Avatar
throb

Community Member, 23 Posts

8 March 2009 at 7:04pm

actually, this came from a clean install of 2.3.0 and the snv checkout i did yesterday (friday) early afternoon.

it should be as clean as it gets.

rob

Avatar
UncleCheese

Forum Moderator, 4096 Posts

9 March 2009 at 3:29am

Edited: 09/03/2009 3:30am

Try adding on or below line 155 of ImageGalleryPage.php:

$manager->enableUploadDebugging()

You'll get a debug window in the upload that will tell you the error that is being thrown.

Avatar
throb

Community Member, 23 Posts

9 March 2009 at 4:09am

here is all the debug data...
thanks for the help and support, sir.

---SWFUpload Instance Info---
Version: 2.2.0 Alpha
Movie Name: SWFUpload_0
Settings:
   upload_url: http://localhost/ss/ImageGalleryManager_Controller/handleswfupload
   flash_url: http://localhost/ss/swfupload/javascript/swfupload.swf?swfuploadrnd=107895548
   use_query_string: false
   file_post_name: swfupload_file
   post_params: [object Object]
   file_types: *.jpg;
   file_types_description:
   file_size_limit: 102400
   file_upload_limit: 20
   file_queue_limit: 20
   debug: true
   prevent_swf_caching: true
   button_placeholder_id: spanButtonPlaceholder
   button_image_url: http://localhost/ss/swfupload/images/XPButtonNoText_160x22.png
   button_width: 160
   button_height: 22
   button_text: <span class='button'>Upload Images...</span>
   button_text_style: .button { font-family: Helvetica, Arial, sans-serif; font-size: 12px; }
   button_text_top_padding: 4
   button_text_left_padding: 5
   button_action: -110
   button_disabled: false
   custom_settings: [object Object]
Event Handlers:
   swfupload_loaded_handler assigned: true
   file_dialog_start_handler assigned: true
   file_queued_handler assigned: true
   file_queue_error_handler assigned: true
   upload_start_handler assigned: true
   upload_progress_handler assigned: true
   upload_error_handler assigned: true
   upload_success_handler assigned: true
   upload_complete_handler assigned: true
   debug_handler assigned: true

SWF DEBUG: SWFUpload Init Complete
SWF DEBUG:
SWF DEBUG: ----- SWF DEBUG OUTPUT ----
SWF DEBUG: Build Number: SWFUPLOAD 2.2.0 Alpha 2008-10-17
SWF DEBUG: movieName: SWFUpload_0
SWF DEBUG: Upload URL: http://localhost/ss/ImageGalleryManager_Controller/handleswfupload
SWF DEBUG: File Types String: *.jpg;
SWF DEBUG: Parsed File Types: jpg,
SWF DEBUG: File Types Description: (*.jpg;)
SWF DEBUG: File Size Limit: 104857600 bytes
SWF DEBUG: File Upload Limit: 20
SWF DEBUG: File Queue Limit: 20
SWF DEBUG: Post Params:
SWF DEBUG: controllerFieldName=ImageGalleryPage
SWF DEBUG: AlbumID=1
SWF DEBUG: dataObjectClassName=ImageGalleryItem
SWF DEBUG: dataObjectFieldName=GalleryItems
SWF DEBUG: fileClassName=ImageGalleryImage
SWF DEBUG: controllerID=5
SWF DEBUG: fileFieldName=Image
SWF DEBUG: ----- END SWF DEBUG OUTPUT ----
SWF DEBUG:
SWF DEBUG: Event: fileDialogStart : Browsing files. Multi Select. Allowed file types: *.jpg;
SWF DEBUG: Select Handler: Received the files selected from the dialog. Processing the file list...
SWF DEBUG: Event: fileQueued : File ID: SWFUpload_0_0
SWF DEBUG: Event: fileDialogComplete : Finished processing selected files. Files selected: 1. Files Queued: 1
SWF DEBUG: StartUpload: First file in queue
SWF DEBUG: Event: uploadStart : File ID: SWFUpload_0_0
SWF DEBUG: Global Post Item: controllerFieldName=ImageGalleryPage
SWF DEBUG: Global Post Item: AlbumID=1
SWF DEBUG: Global Post Item: dataObjectClassName=ImageGalleryItem
SWF DEBUG: Global Post Item: dataObjectFieldName=GalleryItems
SWF DEBUG: Global Post Item: fileClassName=ImageGalleryImage
SWF DEBUG: Global Post Item: controllerID=5
SWF DEBUG: Global Post Item: fileFieldName=Image
SWF DEBUG: ReturnUploadStart(): File accepted by startUpload event and readied for upload. Starting upload to http://localhost/ss/ImageGalleryManager_Controller/handleswfupload for File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress (OPEN): File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadError: HTTP ERROR : File ID: SWFUpload_0_0. HTTP Status: 500.
SWF DEBUG: Event: uploadComplete : Upload cycle complete.
Error Code: -200, File name: Rainbow on the last day of 2008.jpg, File size: 1190980, Message: 500

Avatar
UncleCheese

Forum Moderator, 4096 Posts

9 March 2009 at 9:16am

Edited: 09/03/2009 9:17am

A 500 error is pretty ambiguous. Could be a lot of things. Ensure the following:

- There is no user authentication that might be blocking out the server request
- File is not too large. Check your post_max_size and upload_max_filesize settings in PHP.
- Permissions errors or anything else that might cause the server to reject the file.
- Try a variety of file sizes and types and filenames and ensure that all of them fail the same way.

Do you have any PHP logs? Those are useful for grabbing a verbose error. PHP errors won't be reported to Flash since it causes the request to fail. All you'll get is a 500 error. Even a simple syntax error will cause it.

If you're on Mac and running Leopard, I'd like to screenshare with you through iChat if possible and hopefully figure out what's going on. I'm also working on a long overdue verbose debug mode for the SWFUpload module, which can probably help you.

Sorry you're experiencing this. It's by far the most common bug I have with SWFUpload, and the more exposure I get to these incidents, the more I can iron it out.

Avatar
throb

Community Member, 23 Posts

9 March 2009 at 9:22am

Edited: 09/03/2009 9:26am

I tried changing my memory usage in php.ini and while it lets me upload larger images, etc to other systems (wordpress) it doesn't sort this issue.

the image I am trying to upload in this case is a very small image that's <20kb. Well, the old one in the other post was not but the one I just tried is.

I am more than happy to schedule an iChat with you for some screen sharing goodness. I am on Leopard 10.5.6.
email me (you have my email from before I imagine) and I will get you my IM details.
We can figure out a time then. Thanks for looking into this.

rob

Avatar
Stephan

Community Member, 55 Posts

9 March 2009 at 10:10pm

Edited: 09/03/2009 10:11pm

Hello,
thanks for the great work wih the image gallery.
We have this running on windows with IIS6 and it works very good.
But we have one minor issue:
Even if there is only one album (we renamed the default one), we do get the overview page of the albums.
On the overview there is only one album shown (which is correct).

We downloaded the gallery (0.6.4) from your website.

TIA Stephan

Avatar
UncleCheese

Forum Moderator, 4096 Posts

10 March 2009 at 3:56am

You've downloaded the old version of the ImageGallery. Delete it, as well as the "gallery" module. Then install these via SVN checkout:

svn co http://carlinowebdesign.svn.beanstalkapp.com/modules/trunk/dataobject_manager
svn co http://carlinowebdesign.svn.beanstalkapp.com/modules/trunk/swfupload

run a dev/build

svn co http://carlinowebdesign.svn.beanstalkapp.com/modules/trunk/image_gallery

Please note, the ImageGallery module requires 2.3.

Once the module reaches a stable state, I'll post it to my website as a ZIP file.

Go to Top