Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Image Gallery Extension: Testers Needed


Reply

417 Posts   77959 Views

Avatar
UncleCheese

14 March 2009 at 9:09am 4085 Posts

Unfortunately, a white screen doesn't leave much to go on. You really need to turn up your error reporting and find out what error PHP is throwing. It could be a syntax error, a memory error, permissions error.. hard to say. But since it's not happening on any of the other installations, I think it's safe to say it's got something to do with your setup.

Do you have any logging set up? I can't imagine developing a website without some sort of error reporting. Do you just guess?

Avatar
morph

14 March 2009 at 9:13am Community Member, 4 Posts

thats the main problem!

i'm a provider, SS runs fine on MY machines (including dev-server and productive enviroment)...

but that customer wants to run his website on another machine, so i have to fight against invisible error-messages :D

we'll see if i can reach his supportteam so they should enable error-messaging for a few hours.

Avatar
UncleCheese

14 March 2009 at 9:20am 4085 Posts

Well I can understand the objection to enabling error reporting on a production box, but that's why you set up logging. There should be a way for you to browse PHP error logs somehow. No one leaves errors uncaptured. That's just crazy.

Avatar
morph

14 March 2009 at 9:31am (Last edited: 14 March 2009 9:45am), Community Member, 4 Posts

haha, ini_set is a nice function

Parse error: syntax error, unexpected '}' in /tmp/silverstripe-cache-home-1516bc-cms/.cache.home.1516bc.cms.image_gallery.templates.Layout.ImageGalleryPage_album.ss on line 9

back on track :)

but i can't find any errors in that file, i didn't make any changes :/

edit:

error found, seems to be an uploaderror, there are some fileparts missing :|

sorry for that!

Avatar
UncleCheese

14 March 2009 at 10:07am 4085 Posts

Just checked in a patch for images appearing before they're ready to be clicked.

Avatar
dendraya

15 March 2009 at 2:26am Community Member, 2 Posts

hi UncleCheese!

i really like your image gallery extension :) - but i would love to see it showing the images with sth like [url=http://devkick.com/lab/galleria/]galleria[/url], because i think it would be great if there were a way of displaying the images without a pop-up... unfortunately i'm not that good at programming, but if it's not too hard to implement, i would try if you give me some starting points...

Avatar
UncleCheese

15 March 2009 at 4:58am 4085 Posts

It's entirely possible. The templates that come with the ImageGallery module are by no means intended to be used in the final production of your web site. They're meant to just get you started and show you what controls are available.

For a custom UI, you can select "None" for your popup style, and include any javascript you need to in your template. Then just follow the instructions on the Galleria site on how to markup your images and captions, etc..

It's unlikely that I'll be supporting Galleria, since it runs on MooTools. I'm much more likely to implement a SlideshowPro extension.

But like I said, it doesn't mean it's impossible for you to do it. It's actually pretty simple.

Avatar
dendraya

15 March 2009 at 5:13am Community Member, 2 Posts

then i'll give it a try and see if i can manage to get it working the way i want with galleria ;)

thx for the help.