Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Image Gallery Extension: Testers Needed


Reply


417 Posts   78434 Views

Avatar
boombox

Community Member, 44 Posts

17 March 2009 at 2:56pm

Edited: 17/03/2009 2:57pm

Two Errors Picked up with new installation of the Image Gallery Module
Greetings : I have installed a fresh version of SS 2.3.0 and latest SVN of the Dataobjectmanager | SWFUpload | ImageGallery

1. Created a new Image Gallery Page only shows a blnak page with error mesage
"FileDataObjectManager::__construct() -- could not determine has_one relationship with a File object"
This is due to line 49 of FileDataObjectManager.php in Dataobjectmanager
which I commented out as below   
//die('<strong>Error</strong>: FileDataObjectManager::__construct() -- could not determine has_one relationship with a File object.');

2. Albums Tab > edit the default abum
The Modal dialog shows
"Fatal error: Call to a member function getErrors() on a non-object in \sapphire\forms\Form.php on line 509"
This line in Form.php states

if($this->validator->getErrors()) {
         if(!isset($attributes['class'])) $attributes['class'] = '';
         $attributes['class'] .= ' validationerror';
      }
So looks like a validation error on the album form

Same issue when trying to add a new album
Not sure what the issue is here?

Avatar
UncleCheese

4085 Posts

17 March 2009 at 4:52pm

Do another checkout. I accidentally checked in some bad code.

Avatar
boombox

Community Member, 44 Posts

18 March 2009 at 1:08am

Hi Uncle Cheese
Did an SVN check out and saw the file FileDataObjectManager.php was updated - Bug 2 is still showing
i.e can't create the a new album - was there any other files not checked in?

Thanks for your assistance - this is a great module!

Avatar
UncleCheese

4085 Posts

18 March 2009 at 2:24am

Edited: 18/03/2009 2:26am

Something weird is going on. I'm running 2.3, and my line 509 is not what yours is. Are you sure you're running the right version of SS?

My line 509 of Form.php is a comment.

    * form submissions, all other HTTP methods are

Edit: More info -- the string "validator->getErrors()" is unmatched in my Form.php.

Avatar
UncleCheese

4085 Posts

19 March 2009 at 3:54am

The slideshow_pro module is ready for testing. The SVN is:

svn co http://carlinowebdesign.svn.beanstalkapp.com/modules/trunk/slideshow_pro

Avatar
Joshuarr

Community Member, 37 Posts

20 March 2009 at 6:04pm

Hey Cheese,
I've been toying around again today and have a couple things. I just checked out so I'm up to date. This has come so far. I'm impressed and super grateful for your hard work on this module.

First off, when on the 'photos' tab, the show X number of results select doesn' t seem to work. I'm trying to rearrange a gallery with 13 pics and I can't get them all to show up, which makes reordering the last few images impossible. (An improvement might be to have a way to move a particular image to a particular page. Interface wise I am imagining a drop box type thing but a checkbox or something might suffice.)

Secondly, I've been trying to figure out a way to have album specific information show up. For example, if I had a gallery holder called 'Clothing', and albums within called 'Hats' and 'Coats' It would be nice to have the page title be 'Clothing - Hats' instead of just 'Clothing'

Third, anyway you can make it so that we don't have to use square thumbnails? I'm currently replacing the auto generated images with rectangular images to workaround this limitation, and it's not too toilsome, but just a thought.

Finally, I've come across a scenario wherein I want to turn off the lightbox for one particular album within a gallery and just have the thumbnails (large ones in this case). Any idea how to achieve that? Alternately, being able to set different sizes for the lightbox images would be nice. This is the main issue I'm currently beating my head against.

Thanks again mate, this is stellar.

Josh

Avatar
UncleCheese

4085 Posts

21 March 2009 at 4:12am

Edited: 21/03/2009 4:13am

Hey, Joshuarr,

I just spent so long trying to figure out what was going on with the page size problem. Finally I discovered it was my own idea of a usability feature that was getting in my way. The ImageGallery Manager was programmed to set its own page size based on the value you had selected in the Configuration tab. The idea being that the CMS would reflect exactly what was on your website. All the pages would be the same. But that was forcing the per page value no matter what, and getting in the way. So I've just dropped it for now.

==>As far as cross-page sorting, there is no such thing. The "Allow drag and drop" checkbox should expose all of your records. That feature may have been compromised by the above bug.

==>To display the Gallery name along with the Album name, simply create your own ImageGalleryPage_album.ss. Those templates are meant to be overriden.

==>Non-square thumbnails are in the works.

==>Lightbox size can be set in the Configuration tab in the Normal Size field.

==>To disable the lightbox and show thumbnails only, choose "None" for the popup style.

Anyway, do an SVN update and let me know how it goes.

Avatar
Joshuarr

Community Member, 37 Posts

21 March 2009 at 7:14am

Thanks!

==>As far as cross-page sorting, there is no such thing. The "Allow drag and drop" checkbox should expose all of your records. That feature may have been compromised by the above bug.

Resolved with latest checkout.

==>To display the Gallery name along with the Album name, simply create your own ImageGalleryPage_album.ss. Those templates are meant to be overridden.

I have done - the issue is really that I want different configurations for each album within a gallery. I am going to try instantiating a new gallery for each album, but I don't think it's ideal.

==>Non-square thumbnails are in the works.
cool. the only issue with manually overwriting the files is when I flush the page.

==>Lightbox size can be set in the Configuration tab in the Normal Size field.
again, for the gallery but not the individual albums.

==>To disable the lightbox and show thumbnails only, choose "None" for the popup style.
Then you still get links though. And again this is only modifiable for the gallery not the individual albums.