Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PDFGeneration - Anyone tried it??


Reply

26 Posts   7388 Views

Avatar
Willr

19 August 2010 at 9:33pm Forum Moderator, 5511 Posts

On the topic of PDF generation, during my GitHub lurking I found another PDF / SilverStripe implementation using Flying Saucer - http://github.com/nyeholt/silverstripe-pdfrendition

No idea on the state of that but another example to try out :)

Avatar
contigo

27 August 2010 at 11:40am (Last edited: 27 August 2010 11:56am), Community Member, 16 Posts

We had similar troubles doing html-to-pdf conversion. In the recent past we've has some success using LiveDocX. It's a Zend Framework package. It requires you to start with a Docx file as a template...

summary - http://www.phpclasses.org/blog/post/103-New-approach-to-generate-PDF-using-PHP-with-Zend-Framework.html
details - http://www.phplivedocx.org/articles/pdf-generation-with-zend-framework/

-Billy

Avatar
swaiba

29 September 2010 at 10:32pm Forum Moderator, 1796 Posts

Hey Uncle Cheese - bumping this as it is rising in my todo list, any chance of the details of your, no doubt, excellent solution? :)

Avatar
BLU42 Media

30 September 2010 at 3:51am (Last edited: 30 September 2010 4:11am), Community Member, 71 Posts

I ran into the same snarly mess that Uncle Cheese did of renaming files and classes to work with ManifestBuilder.

I just uploaded my version to SS and I'm posting here too - hopefully it will help someone out!

-John

Attached Files
Avatar
UncleCheese

30 September 2010 at 4:14am 4085 Posts

OK, guys. I'll put this one on the frontburner for my next LeftAndMain tutorial. Thanks for your interest!

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
Peter_SS

30 September 2010 at 7:04am Community Member, 19 Posts

nice uncle cheese!

Avatar
kuenkuen82

21 October 2010 at 11:03pm (Last edited: 3 November 2010 5:25pm), Community Member, 41 Posts

Using the smartpdf module

   $pdf = new DOMPDF();
   $html = "<head></head><body><p>Hello World</p></body></html>";
   $pdf ->load_html($html);
   $pdf->set_paper("letter", "portrait");
   $pdf->render();
   $pdf->stream("dompdf_out.pdf");

I get this error :
Fatal error: Class 'Frame_Tree' not found in /var/www/vhosts/website.com/httpdocs/smartpdf/code/include/Stylesheet.php on line 663

I've tested the DOMPDF package on my webserver as it's working fine, so I can't really see where I'm going wrong

Avatar
Borgopio

11 December 2010 at 6:16am Community Member, 14 Posts

I've tried http://github.com/nyeholt/silverstripe-pdfrendition. It's simple and the result is quite good but the pdf won't include images :(

I wish to try also smartpdf but cannot understand how to make it work. Any help?