Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

For all who want YouTube on 2.3


Go to End
Reply

19 Posts   3388 Views

Avatar
Matt Hardwick

25 February 2009 at 8:54am Community Member, 61 Posts

I downloaded the current stable and changed line 173 in YouTubeService.php from

$current_url = Director::currentURLSegment(); to $current_url = Controller::curr()->URLSegment;

This means I can still have side navigation, and it doesn't load up full screen because the JavaScript includes are busted on the later versions.

Avatar
Adsum

2 March 2009 at 3:34am Community Member, 3 Posts

Thank you very much, Matt. Works fine! This solved my problems with YouTube Gallery 0.1 on Silverstripe 2.3.

Avatar
Matt Hardwick

2 March 2009 at 3:42am (Last edited: 2 March 2009 3:42am), Community Member, 61 Posts

I have since noticed that the times are screwed... So a video that is 1:55 is put as 1.9 minutes. When I figure out how to sort it I will post. Also pagination isn't working.

Avatar
Flynn42

17 March 2009 at 12:41am Community Member, 1 Post

Thanks Matt! I was having similar problems with the youtubeservice module. You saved me from multiple days of coding hell!

Avatar
Briohny

18 March 2009 at 4:47am Community Member, 199 Posts

Hey Matt... what about 2.2.3? Does YouTube module work with this version. I installed it and after db/build etc the YouTube page produces the following error:

Fatal error: Call to undefined function curl_init() in C:\wamp\www\mccools\sapphire\api\RestfulService.php on line 83

Any ideas?

Avatar
Matt Hardwick

18 March 2009 at 4:57am Community Member, 61 Posts

I would guess that is actually something more to do with your install, as it looks like a CURL error, and is not something related to the problem outlined in this thread.

Are you using the stable version of YouTube??

Avatar
Briohny

18 March 2009 at 5:06am Community Member, 199 Posts

Yes, it's v0.1.0

I'll try uninstalling and re-installing again to check. Will get back to you. Thanks.

Avatar
Briohny

18 March 2009 at 5:15am Community Member, 199 Posts

No, still not working. I did a fresh install. Same error. I noticed that the YouTube documentation says to use SS v2.2.0 but you got it to work with 2.3. Any ideas?

Go to Top