Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Preview: SlideshowPro Module


Reply


70 Posts   13957 Views

Avatar
UncleCheese

Forum Moderator, 4096 Posts

8 September 2009 at 7:22am

Thanks, Banal,

This module is very much the neglected step child of all my modules. It needs a lot of work and I am just don't have the technical chops with SSP to be investing a lot of time into it. AFAIK, everything is working well right now. I just pushed a site into production using each album as a different page, and I plan to push a tutorial into the documentation soon.

While I have, you, can you take a look at the EventCalendar thread in here and see if you can help out with a character encoding issue? I'm puzzled.

Avatar
Valorinbattle

Community Member, 95 Posts

7 December 2009 at 4:07pm

Is there a current release of this that works? I purchased the SlideShow Pro Standalone and tried to integrate that per Willr's instructions in a different post, but it didn't work.

I've read thru all the posts here and added the DataObjectManager, SWFUploadeder, ImageGallery, and what I think is the current SlideShowPro module. The Albums work, the photos work, but nothing is displaying on my page.

I saw the YouTube video about this module and noticed that my XMLFilePath is not correct. I don't even know what it should be, but right now it's pointing to http://localhost/modules/slideshow1/xml, which is obviously wrong. But I don't know how to change it.

Bod posted instructions about opening up the .fla file that contains the Slideshow Pro component. I'm not sure what that means - am I to take the slideshowpro.swf file from the Slideshow Pro Standalone folder?

Any help would be much appreciated. Just a little confused here. If someone else has that .fla file and is willing to share, I'd be very grateful!

Thanks!

Avatar
UncleCheese

Forum Moderator, 4096 Posts

7 December 2009 at 4:46pm

No, it doesn't work with the standalone. You have to create a swf file using the SSP component and set the xml file path property as given in on the SWF tab in the CMS. Should be /your-slideshow/xml

Avatar
Valorinbattle

Community Member, 95 Posts

7 December 2009 at 4:49pm

Thanks for the quick reply Uncle Cheese. What is the SSP component?

Avatar
Valorinbattle

Community Member, 95 Posts

7 December 2009 at 8:47pm

Uncle Cheese, so I realized that the SSP component is the .mxp extension I get when I purchase the SlideShow Pro for Flash product. So I've done, followed your instructions, and now I have a working Slideshow Pro page, and working tabs in the CMS - all is great - thanks for the help!

But now I'm wanting to not just have select pages that are Slideshow pages, I want to take that code and place a slideshow in another page - for example, the HomePage page type. How can I do this?

Also, how can I make it so I have two slideshows showing up on the same page?

Again - thank you for your time answering our questions and developing this module in the first place. Very much appreciated!
~ James

Avatar
bod

Community Member, 72 Posts

7 December 2009 at 10:31pm

Edited: 07/12/2009 10:37pm

Hi Valorinbattle,

If you want to save yourself from creating separate swf files for each page, just follow my tip above, here it is again,
-------------------------------------------------------------------------- */
Still works with 2.3.4. Just name the SSP component my_ssp and create an actions layer in the timeline in Flash - on the first frame put the following script

my_ssp.xmlFilePath = ImagesPath;

NB: Make sure your xmlFilePath value in the component Inspector xmlFilePath is blank! Now you can use the same swf file on each page and it will only take the xml data from the page it is in.

- make sure you have the latest version of the module - if in doubt use the svn package
-------------------------------------------------------------------------- */

If however, you wish to show the same slides that is on say the homepage also in the about us section without having to re-set up the album again, do one of two things, either in the CMS control panel right click and choose duplicate page and rename it to about us, this should copy everything inc the album set up - the alternative is to code the actionscript above to point to the home page xml file path, for example instead of the above code on the actions layer in the swf you would put something like this

my_ssp.xmlFilePath = "http://localhost/homepage/xml";

Two very different approaches but both should work.

HTH

Avatar
Valorinbattle

Community Member, 95 Posts

8 December 2009 at 6:10am

Thank you Bod. I have tried it but I keep getting "error undefined" errors when I'm trying to export the .swf
I will keep trying - must be doing something wrong.

As to my other question - is it possible to have 2 different slideshows on the same page?

~ Valorinbattle

Avatar
Valorinbattle

Community Member, 95 Posts

8 December 2009 at 2:56pm

Bod, I really must be missing something here. I keep getting the same errors whenever I try to add your action script. Here's a screenshot of what I've done, including my error.

Thanks for your help.

~ Valorinbattle

Attached Files