Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem with UserForms Module


Go to End
Reply


9 Posts   1845 Views

Avatar
neddyf

Community Member, 2 Posts

28 March 2009 at 2:36am

Hello,

I made an update to silverstripe 2.3.1 an found that userforms has to be integrated as module.

So I downloaded from trunk (yes, and renamed to 'userforms' in the SilverS-Root-Dir) and started /dev/build.

Now I find new page-type user-defined-form and can create.

=> BUT the "Form"-Tab only shows this two rows at the beginning
=> MISSING the area where to drop the fields (as shown on the picture of the module-page and as I saw in SilverS 2.2)

* Add: * Text * Checkbox * Dropdown * Radio * Email * Heading * Date * File * Checkboxes * Member List
=> MISSING AREA
* Add: * Text * Checkbox * Dropdown * Radio * Email * Heading * Date * File * Checkboxes * Member List

(Javascript is enabeld. All other things work.)

I installed a new Instances, same result everytime :-(
Do you have any ideas ?

Thanks a lot for helping.
Ned

Avatar
UncleCheese

Forum Moderator, 4096 Posts

28 March 2009 at 4:49am

Mine seems to be missing the stylesheet ever since I upgraded to 2.3 and used the module. Just a bunch of unstyled links in lieu of the buttons that used to be there. Anyone else?

Avatar
CriaturaCreativaStudio

Community Member, 73 Posts

29 March 2009 at 9:51am

i'm having the same problem here, the GUI (drag an drop items, fields, etc) doesn't work, i only read text labels. When i click on them, nothing happens...

Avatar
The Serch

Community Member, 1 Post

31 March 2009 at 8:38am

SOLVED!

I don't you know if you (CriaturaCreativaStudio) were having the same issue (the Form tab is there and you can see the type of fields to add but when you clicked them nothing happens....) .

The thing was it was not loading the FieldEditor.js file which animates this panel and it was because I placed userforms folder under mysite folder.

BAD:
root
|--> /mysite
|--> /userforms

Instead, put it on the same level as your site folder

RIGHT:
root
|--> /mysite
|--> /userforms

Once this is done, run /dev/build again

I hope this works

Avatar
UncleCheese

Forum Moderator, 4096 Posts

31 March 2009 at 8:43am

Hmm.. yeah, it certainly doesn't belong in the mysite folder. I've got it in the right place. Nice to know it's a JS issue, though. At least now I know where to look.

Avatar
craigrg

Community Member, 2 Posts

1 April 2009 at 12:12am

Can any one tell me how to fix this problem? not very good with JS

Avatar
Bluefruit

Community Member, 6 Posts

3 April 2009 at 11:04pm

Edited: 03/04/2009 11:04pm

Rename the module folder to 'userforms' and locate it in the root directory (not mysite).

Done the trick for me anyway!

Avatar
neddyf

Community Member, 2 Posts

5 April 2009 at 10:55am

Edited: 07/04/2009 9:00am

The JS is embedded:
..
<script type="text/javascript" src="http://localhost/myproject/userforms/javascript/FieldEditor.js?m=1229310604"></script>
..
And "userforms" (renamed to) is in the root-directory of the Installation.

.. but still not working.

Go to Top