Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

curl_setopt Flickrmodule


Reply


3 Posts   1583 Views

Avatar
dconel

Community Member, 21 Posts

10 April 2009 at 9:49pm

I don't know how to tell it in Englisch, but the error "came out of nothing". I've put the source and the trace in the attach file.

[Warning] curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set
GET /foto-s/

Line 103 in /home/dirk/domains/meifeest.com/public_html/sapphire/api/RestfulService.php

Is it something with the API i have?

Attached Files
Avatar
simon_w

Forum Moderator, 474 Posts

10 April 2009 at 10:05pm

This error will only appear when you're running in dev mode. It is because your host has open_basedir enabled, which is restricting the usage of certain curl options that the Flickr module is using.

To fix this, you could either comment out line 103 in sapphire/api/RestfulService.php or get open_basedir disabled. If you're on a shared host, the former will be the easiest as most hosts will be unwilling to disable open_basedir.

Avatar
dconel

Community Member, 21 Posts

10 April 2009 at 10:51pm

hmm, I've put Director::set_environment_type('live'); in _config.php but I still get that error.