Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SWFUpload Installation Problem... maybe...


Reply

3 Posts   1737 Views

Avatar
trevwilcox

15 April 2009 at 12:21pm Community Member, 7 Posts

When I tried to install SWFUpload0.6 in SS v2.3.1, I put the swfupload file into the SS root directory (C:\wamp\www\SilverStripe-v2.3.1\) as per the above instruction. Then when I ran

http://localhost:3000/SilverStripe-v2.3.1/db/bu...

It appeared as if nothing happened. Normally if there are updates to the database, stuff will show up in a different color. But this time, it was as if the database was already up to date.

I did notice afterwards that there's also a SWFUpload folder in jsparty - but with no php files.

Can't figure out what, if anything, I did wrong. Does this mean that in SS v 2.3.1 it's already installed?

Any help would be very much appreciated.

Sincerely
Trevor

Avatar
Ben Gribaudo

16 April 2009 at 12:19am (Last edited: 16 April 2009 12:21am), Community Member, 181 Posts

Hi Trevor,

Since [url=http://code.google.com/p/swfupload/]SWFUpload[/url] doesn't interact with the database, you won't see any activity in /dev/build's output as a result of installing it.

As to your second question, yes, SWFUpload v 2.0 is included with SS v 2.3.1. FYI, the current version of SWFUpload ([url=http://code.google.com/p/swfupload/]available for download[/url]) is 2.2.0.1.

Hope that helps!
Ben

Avatar
UncleCheese

16 April 2009 at 1:23am 4085 Posts

Ben is correct. The dev/build will just rebuild the class manifest to make the SWFUploadField available for use. I've made several updates to the module since I last posted a ZIP. You can check it out from SVN at:

http://carlinowebdesign.svn.beanstalkapp.com/modules/trunk/swfupload

Or just give me a few hours to export the svn, zip it, and post it.