Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Calendar module: no calendar displays


Go to End
Reply

19 Posts   2491 Views

Avatar
ThrashCardiom

19 April 2009 at 4:17am (Last edited: 19 April 2009 4:28am), Community Member, 20 Posts

I have installed the calendar module but cannot get it working correctly. I can create calendar pages and event pages but no calendar is ever displayed on the draft/published site. Everything else on the page is correct - just no calendar or events.

If I add $CalendarWidget to my Page.ss I do get the month calendar displayed so something is working.

Also, in the Configuration tab I don't have the "Event description behaviour" field or the "Word count for event description..." field as described on the installation page. All I have is:

* Number of Events to display on default view
* Default date header..
* Number of future dates..

SS version is 2.3.1
Calendar module is the r33 download. However I have also tried the direct download from the bluehousegroup.svn site

Any ideas?

Avatar
UncleCheese

20 April 2009 at 4:39am 4085 Posts

The fields you're describing on the Configuration tab no longer exist. I need to update the documentation. I'm not really clear about what isn't working by your description, however. Do you not have a Calendar page in your SiteTree? Have you created events? Assigned them dates? A link would be really helpful.

Avatar
ThrashCardiom

20 April 2009 at 7:07am Community Member, 20 Posts

Yes, I have the Calendar page in the site tree. I have created events, assigned dates etc. The Calendar page is in the menu on the published site but when I click on the menu item, all I get is a page without any content. Obviously I have missed something in the set up of it but I have followed the documentation several times step by step to no avail.

I can't give you a link as it lives on an internal server.

Avatar
UncleCheese

20 April 2009 at 8:21am 4085 Posts

What do you mean by "no content?" Does the page say "There are no events?" Does if have a page title? Provide a screenshot if you can.

Avatar
ThrashCardiom

20 April 2009 at 8:35am Community Member, 20 Posts

Screenshot of the Calendar page attached:

Attached Files
Avatar
UncleCheese

20 April 2009 at 11:18am 4085 Posts

Weird. Can you do a ?showtemplate=1 and see if the Calendar.ss template is ever getting called?

Avatar
ThrashCardiom

20 April 2009 at 2:34pm Community Member, 20 Posts

Nothing. Not a sausge.

Avatar
otherjohn

9 May 2010 at 2:57am Community Member, 125 Posts

Exact same thing is happening to me.
I am on SS 2.4.0
With Events Calendar r106

Only mods on the site is that I am running the Sapphire and cms folder via a symlink.

Go to Top