Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Copy module to SS root, run dev/build, nothing happens


Reply

3 Posts   957 Views

Avatar
david_nash

4 May 2009 at 4:37pm Community Member, 55 Posts

I'm trying to install the data object module. I've copied the directory to my silverstripe root folder and when I run /dev/build nothing happens - it shows me the existing db tables and doesn't see the new files. The permissions are fine.

Any ideas?

Avatar
rbquirke

4 May 2009 at 9:59pm Community Member, 70 Posts

Hard to guess with such a general thing.

First off, make sure your brain isn't playing tricks on you. Open a url within the module that should work if all the files are where you think they are, for example:

MYSITENAME/dataobject_manager/images/add.gif

- if you can see the add.gif, then the files are where they should be...

- next thing I would check is to make sure it isn't already installed: maybe it isn't updating because it has installed it already?

Avatar
david_nash

5 May 2009 at 5:24pm Community Member, 55 Posts

Thanks rbquirke, some good tips!

I could see the add.gif in the browser.

I think maybe it was installed, but I seriously don't remember seeing anything new in dev/build.

I installed the hasmanyfilemanager and that worked fine, so I assume there was something wrong with my dataobjectmanager usage. I don't think I need to use it so I'm going to avoid the problem for now.

Thanks again.