Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Cannot use User Forms Module


Reply

10 Posts   2720 Views

Avatar
AMcD

4 June 2009 at 11:29pm Community Member, 2 Posts

Big Bang Creative - Looks like it can't find the css and js files, probably because the directory name is wrong.
It doesn't make it clear in the instructions, but the module directory must be called userforms.

So rename it from userforms_v0.1.0 to userforms before or after you upload it.

Avatar
Big Bang Creative

10 June 2009 at 2:58am (Last edited: 10 June 2009 3:31am), Community Member, 92 Posts

Hi SalvaStripe, I have tried your contact form and I can get it to send with no problems however I can't get the validation to work. I've copied the exact code you posted, does the validation work for you? I can get it to work on the email field but not others.

EDIT/UPDATE: I have this working on SS v2.3.1 perfectly however I have a few sites running v2.2.3 which I cannot upgrade. On the sites running v.2.2.3 everything works apart from the validation. Viewing the source code I see there is no javascript been added at all. Do you think this will even work if I can manually add in the javascript?

Also the form I have working perfectly on SS v2.3.1 only validates against the email address. I have this: $validator = new RequiredFields('cfName', 'cfEmail', 'cfMessage'); but that does not work.