Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

UserForms 0.2


Reply


185 Posts   27765 Views

Avatar
Willr

Forum Moderator, 5513 Posts

15 May 2009 at 1:03pm

Edited: 10/07/2009 5:03pm

We have a new release of the userforms module available: 0.2

We'd appreciate everyone's help testing it, so that we can make a stable release as soon as possible.

Download here: http://www.silverstripe.com/assets/rc/userforms-v0.2.tar.gz
Post bug reports here: http://open.silverstripe.com

Note 1) - To get this to run you need to be using 2.3.2 beta at least for this to work. 2.3.1 or lower will not with this release.

Note 2) - If you have current userforms on your site this will break them. You might like to take a full backup and then recreate the forms once you have installed this module

Thanks,

Avatar
Marco_D

Community Member, 20 Posts

15 May 2009 at 6:24pm

Edited: 10/07/2009 5:03pm

The download link is dead... ;)

Avatar
rodneyt

Community Member, 8 Posts

16 May 2009 at 1:59pm

Edited: 10/07/2009 5:03pm

As noted by other poster - that link is dead.

Will we get this by checking out trunk from the SVN?

What is the mechanism to chec/verify version numbers of modules after download/installation?

Thanks

~ Rodney

Avatar
rodneyt

Community Member, 8 Posts

16 May 2009 at 2:08pm

Edited: 10/07/2009 5:03pm

Further to last email...

svn co http://svn.silverstripe.com/open/modules/userforms/trunk
...
Checked out revision 76992.

ChangeLog reports
0.1.0
- Initial release

If there is a new version available, why is it not in the SVN?

~ Rodney

Avatar
Willr

Forum Moderator, 5513 Posts

16 May 2009 at 6:59pm

Edited: 10/07/2009 5:03pm

- It is in SVN - http://open.silverstripe.com/browser/modules/userforms/tags/rc/0.2

- The ChangeLog just hasn't been updated for 0.2 - I will do this once 0.2 is released as stable / next week.

- Download Link is strange - works for me. I have reuploaded it into the CMS - http://www.silverstripe.com/assets/rc/userforms-v0.2.tar

Can you let me know if that url works for you.

Avatar
Cem

Community Member, 31 Posts

16 May 2009 at 9:19pm

Edited: 10/07/2009 5:03pm

Hi Will,
The last URL works but downloads an empty tar file so I had to go and checkout from svn.
As for feedback:The Field Configuration options do work again(Yay!) under 2.3.2 beta.
Thread:http://www.silverstripe.org/all-other-modules/reply/260172
You guys do an amazing job !Thumbs up!
Cheers
Cem

Avatar
rodneyt

Community Member, 8 Posts

17 May 2009 at 10:35am

Edited: 10/07/2009 5:03pm

Thanks Will,

That SVN url is wrong, the correct one is: http://svn.silverstripe.com/open/modules/userforms/tags/rc/0.2
Checks out revision 77002

~ Rodney

Avatar
rodneyt

Community Member, 8 Posts

17 May 2009 at 10:43am

Edited: 10/07/2009 5:03pm

Installed userforms 0.2. When I view the forms page it doesn't look like the UI I have seen for userforms elsewhere (e.g. documentation, silverstripe demo site). Please see attached image. If I select a form element from one of the drop-downs and click "Add" instead of adding anything the page shows a "Saving" message, then "Saved (pagename)". The form element does not appear. This was the same behavior I was seeing with userforms 0.1

Any idea what's going on here?

Thanks in advance...

~ Rodney

Attached Files