Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Can Gallery open images in a normal page?


Reply


7 Posts   1235 Views

Avatar
Jacknife

Community Member, 16 Posts

3 June 2009 at 12:08am

Hi all,

I am using Gallery and I don't want to use the pop up functionality but just have the image open on a normal page (templated as the rest of the site), I currently have over 150 images with more to come so don't want to create all the pages manualy and link to them.

Any ideas?

Cheers

:D

Avatar
UncleCheese

Forum Moderator, 4094 Posts

4 June 2009 at 1:37am

Can't you just choose popup style "none?"

Avatar
Jacknife

Community Member, 16 Posts

4 June 2009 at 1:39am

Where is that option? I have looked and looked for anything that might be like that :(

Avatar
UncleCheese

Forum Moderator, 4094 Posts

4 June 2009 at 2:23am

It's been in there for a long time. When was the last time you ran an update?

Avatar
Howard

Community Member, 215 Posts

4 June 2009 at 2:29am

Oh i think that Jacknife is using the old gallery module not your new fancy schnacy one! Jacknife I would reccommend upgrading to the new gallery module that has been developed by UncleCheese - more info here [url]http://www.silverstripe.org/imagegallery-module/[/url] best to use the 'unstable trunk' via svn as the zip files tend to get outdated pretty quick.

Then you will be able to use the "none" popup style.

Avatar
UncleCheese

Forum Moderator, 4094 Posts

4 June 2009 at 2:36am

Ahh.. Thanks, Howard.

@Jackknife -- Visit the DataObjectManager forum, and get the SVN info for the three modules -- dataobject_manager, image_gallery, and swfupload. You'll be much happier with the new version :-)

Avatar
Jacknife

Community Member, 16 Posts

4 June 2009 at 9:15am

Thanks guys.

I have upgraded to the new Gallery and have selected the 'none' option. How do I now get this basic image into my templated page?

Sorry to be so stupid, new to SS.

:D