Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

HasManyFiles and SS ver 2.3.2


Reply


6 Posts   1524 Views

Avatar
biapar

Forum Moderator, 435 Posts

8 July 2009 at 8:26pm

Hi,

after add HasManyFile Trunk to SS 2.3.2, I had these error:

[User Error] DataObjectDecorator->setOwner(): Trying to decorate an object of class 'CMSMain' with 'CustomScriptInit', only Dataobject subclasses are supported.
GET /ss/admin

Line 43 in C:\xampp\htdocs\ss\sapphire\core\model\DataObjectDecorator.php
Source

34     * @param DataObject $owner
35     */
36    function setOwner(Object $owner, $ownerBaseClass = null) {
37       if(!($owner instanceof DataObject)) {
38          user_error(sprintf(
39             "DataObjectDecorator->setOwner(): Trying to decorate an object of class '%s' with '%s',
40             only Dataobject subclasses are supported.",
41             get_class($owner), $this->class),
42             E_USER_ERROR
43          );
44          return false;
45       }
46       
47       parent::setOwner($owner, $ownerBaseClass);
48    }
49    

Why?

Avatar
banal

Community Member, 901 Posts

8 July 2009 at 9:51pm

Hi
I'm sorry, the HasManyFileManager currently doesn't play well with SS 2.3.2.
You could either switch to the DocumentObjectManager or wait until I release a fix..

Avatar
Bambii7

Community Member, 254 Posts

21 July 2009 at 10:50am

Hey is there anything I can do to help with the update to hasmanyfilemanager? I got the same error, so went to silver stripe 2.3.0, it works but not how I remember it. I remember it being nicely laid out with image info on the right and drag and drop reordering. You probably already know but I'll post a screen grab anyway.

Attached Files
Avatar
UncleCheese

Forum Moderator, 4094 Posts

21 July 2009 at 1:48pm

You might also want to check out FileDataObjectManager for a module with the same functionality but more features.

Avatar
Bambii7

Community Member, 254 Posts

23 July 2009 at 5:16pm

Edited: 23/07/2009 5:26pm

Thanks UncleCheese
I tried out DataObjectManager but I whats up with "DataObjectManager requires the SWFUpload module." when you navigate to files and images? I can't see the swfupload module. I guess this hasn't been updated with 2.3.2 yet.....?

OPS! Sorry UncleC I found your swfupload module in the unsupported module section. I get some funcky errors when in the assets admin section of 2.3.2. Giving it a go on 2.3.0 now

Avatar
UncleCheese

Forum Moderator, 4094 Posts

24 July 2009 at 1:15am

Hmm.. It's only been tested in 2.3.2. I'm not sure it works in 2.3.0. What errors were you getting?