Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

UserForms V0.2.0 - SilverStripe 2.3.3


Reply

18 Posts   2893 Views

Avatar
tone77

17 August 2009 at 1:10am Community Member, 10 Posts

I just upgraded to SS 2.3.3 and installed the userforms module. An old form that I have shows up, but won't let me edit it. So I created a new dummy page, changed it to a userform page, then tried to add a field, but no luck. When I select the field type and click add, the browser gets redirected to /admin/EditForm and the page is blank.

Any ideas on why this would happen? Once I can add a form to a new page, I will deal with editing the old form.

Avatar
Willr

17 August 2009 at 11:40am Forum Moderator, 5511 Posts

Make sure you have flushed your admin panel - site.com/admin/?flush=1 to reload any cached files. The old javascript or templates may be conflicting.

If that still doesn't fix it then double check you ftped the new directory correctly and all the files exist. Then check your error console in your browser for any javascript errors that could be causing the form to fail.

Also note that the new userforms module is not compatible with the previous versions (for the most part) so you may run into issues updating existing forms.

Avatar
tone77

17 August 2009 at 11:26pm Community Member, 10 Posts

Doing the /admin/?flush=1 helped clear up the blank page. I now see the green 'saved' text that shows up at the bottom, when clicking on the add button. But this still doesn't produce any form fields for me. I click the save button for the page, then refresh and still the form is blank.

I did a wget on this module, so no chance of leaving any files off using FTP. Firebug doesn't show any JavaScript errors, so I guess my next move it to see if there are any new fields in the DB. I'll dig there to see if the new form is even creating a corresponding entry in the DB.

Avatar
cygnet

19 August 2009 at 8:50pm Community Member, 20 Posts

I have the following problem:

Text inside checkboxes shifts down.

you can see how it lool here -> http://tangounderground.com/new-userdefinedform

Has anyone run into sumething similar?

Avatar
Myrdhin

21 August 2009 at 12:11am (Last edited: 21 August 2009 1:42am), Community Member, 67 Posts

Hello,

@bkatous : i have the same problem.

FieldSet::addFieldToTab() Tried to add a tab to object 'Tab' named 'Complétion en cours' - '' didn't exist.

And the solution is : replace in your file userforms/lang/fr_FR.php, line 120 :

$lang['fr_FR']['UserDefinedForm']['ONCOMPLETE'] = 'Complétion en cours...';

by

$lang['fr_FR']['UserDefinedForm']['ONCOMPLETE'] = 'Complétion en cours';

The problem is the last three dots in the traduction. In file /sapphire/forms/FieldSet.php, line 253, function findOrMakeTab(), SilverStripe explode the $tabName (here "Root.Content.Complétion en cours...") with the dot character :

$parts = explode('.',$tabName);

But the result of '...' is '', '' and ''

Hope this help you !

Avatar
cygnet

21 August 2009 at 2:10am Community Member, 20 Posts

sorry, but I don't really understand how it is related with my question. Would you please provide an example if you can.

Avatar
Myrdhin

21 August 2009 at 3:11am (Last edited: 21 August 2009 3:15am), Community Member, 67 Posts

Sorry Cygnet. I answered bkatous, [url=http://www.silverstripe.org/all-other-modules/show/266412#post266412]the first question[/url] in this topic :

Im having problem when i try to add a a new form, i've got this error :

"Error: "FieldSet::addFieldToTab() Tried to add a tab to object 'Tab' named 'Complétion en cours' - '' didn't exist." at line 272 of E:\wamp\www\testSite\sapphire\forms\FieldSet.php"

Avatar
Willr

21 August 2009 at 12:18pm Forum Moderator, 5511 Posts

Hey Myrdhin,

Thanks for pointing this out. I have removed it from the translation entry

http://open.silverstripe.org/changeset/84941

Cheers,