Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Blog Module not working with Mollom/Spam Protection

Go to End

3 Posts   2313 Views


Community Member, 3 Posts

18 September 2009 at 4:16am

I installed a fresh copy of Silverstripe 2.3.3 and the latest Blog Module [0.2.1], Mollom [v0.2], & Spam Protection [v0.2].

I also enabled the spam protection in mysite/_config.php by including

// The following 3 lines enables Mollom Spam Protection

Now when i go to my blog page and click on the sample blop entry title to go to

i get a warning

[Warning] Unknown class passed as parameter
GET /sample-blog-entry/

Line 420 in /sapphire/core/Object.php
# is_subclass_of(SpamProtecterField,DataObject)
Line 420 of Object.php
# Object::prepare_statics(SpamProtecterField)
Line 175 of Object.php
# Object::get_static(SpamProtecterField,extensions)
Line 264 of Object.php
# Object::uninherited_static(SpamProtecterField,extensions)
Line 488 of Object.php

I notice that SpamProtecterField is spelled wrong and should be SpamProtectorField (with an O and not an E in protector)

Anybody else facing this issue?


Forum Moderator, 5521 Posts

18 September 2009 at 3:57pm

If you are using the latest mollom / spam (maybe try the daily builds instead) the typos should be fixed. Try Perhaps the spelling error is from an older version.

You can also try the daily builds of mollom, spam and blog. These are available on their individual download pages and contain slightly more up to date code. Try these (remember to dev/build?flush=1 again).

If after running the latest daily builds doesn't fix it can you do a search for 'SpamProtecterField' in your entire project and see what file (if any) this is referenced in.


Community Member, 3 Posts

19 September 2009 at 12:46am

Thanks willr,

Installing the latest build of the SpamProtection Module & Mollom Module worked.

Installing the latest build of the Blog Module also fixed another bug I was having where clicking on a link in the Browse by Date section produce an error.