Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Calendar


Go to End
Reply

16 Posts   1505 Views

Avatar
richard123

16 October 2009 at 8:29am Community Member, 8 Posts

Hello..

A newbie to SS needing help.

I installed the latest version of the EventCalendar module on a working site but
it has some issues.

1. I can create a Calendar page but it hangs up when I create a CalendarEvent page.
2. I cannot enter any dates - no pop up entry fields.
3. What does "You may add Announcements once you have saved for the first time."
on the Announcements tab means?

I installed the EventCalendar module on a local SS installation and it works fine.
Both versions are 2.3

Please advise.

Thank you.

Attached Files
Avatar
UncleCheese

16 October 2009 at 8:48am 4085 Posts

Are any errors being thrown? Do you have error reporting on? Make sure you set Debug::send_errors_to("your@email.com"); in your _config.php.

Do you have DataObjectManager installed? If so, which revision?

Avatar
richard123

16 October 2009 at 9:31am Community Member, 8 Posts

Hi..

Sorry for being a complete newbie..

Yes - DataObjectManager is installed on the problem site but it
is not installed on my local installation which the calendar works.

How can I know the version for the DataObjectManager?

I have a replica of the live site on my localhost now - it still does not work.

Is there a way to see errors without mailing them?
I work on localhost now so I cannot send emails.

Thanks!

Avatar
UncleCheese

16 October 2009 at 9:47am 4085 Posts

Yeah, make sure your environment is in dev mode.

Director::set_environment_type('dev');

When did you download and install DataObjectManager? I have a feeling that's the culprit. You might have gotten a buggy version.

Avatar
richard123

16 October 2009 at 10:04am Community Member, 8 Posts

Hello..

The installation has an _ss_environment.php file.
I set it there already.
define('SS_ENVIRONMENT_TYPE', 'dev');

The site is already existing and I was not the one who installed the
DataObjectManager module.

If indeed, this is the buggy version, how can I uninstall it and update to the latest version?

Thanks for the quick response.

Avatar
richard123

17 October 2009 at 8:05am Community Member, 8 Posts

Hi..

I upgraded to the latest version of the DataObjectManager (r304)
by deleting the old dataobject_manager folder, add the latest version and ran
/dev/build/?flush=1

I can now see the js pop-up entry fields.
However, I cannot enter dates.

See screenshots for comparison.

Please advise.
Thanks.

Attached Files
Avatar
UncleCheese

17 October 2009 at 8:32am 4085 Posts

Try running an update to 305.

Avatar
richard123

17 October 2009 at 10:57am (Last edited: 17 October 2009 11:22am), Community Member, 8 Posts

Hi...

Still the same.
r305

Also, on the stock SS install, I do not have the
DataObjectManager installed, on the problem site,
it is r305.

Go to Top