Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

All other Modules /

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

NEWSLETTER SUBSCRPTION PUT 'NULL' IN DATABASE


Reply


3 Posts   1092 Views

Avatar
servalman

Community Member, 211 Posts

22 October 2009 at 11:33pm

Edited: 23/10/2009 6:04am

Hi

I have installed almost sucessuffly the Subscrittion module and the Newsletter module.

Things where running smooth but suddendly if I try to add a new member via subdcrition page or the import tab it adds "NULL" to all the field in database any idea why ?

Thank you

T

Avatar
servalman

Community Member, 211 Posts

23 October 2009 at 6:07am

I made some progress (sort of)

Adding members to the email list works with : the newsletter import tab or by editing an exsiting blank entry in the mailing list tab.

What I can not get to work is the s SubscribeForm.php file even tough I'm using the latest trunk for both newsltter and UserForm.

Any idea any one

Thanks

T

Avatar
servalman

Community Member, 211 Posts

23 October 2009 at 10:23pm

Hi

I have just installed the latest trunk for both Userform and Newsletter module :

modules_newsletter_trunk-r90059
modules_userforms_trunk-r90059

I flushed database with http://www.mysite/SilverStripe/dev/build?flush=1

For all the subcription part everything works fine from CSV import to Adding manually.

The only problem I have like everyone else is with the subcription page as it doesn't fill the database even tought It saves the submissions tha I can export in CSV and then import .

I reaaly would love someone that explain me what is not working as the submission form creates the databse fields but don't populate them.

Do I have to flush something else ?

I really need help on that as my client are very impatient to get this worjking without to have to use the export/import solution.

Thanks to anyone that has a clue of what is wrong with SubscribeForm.php

Someone must have the solution somewhere

T