Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Log in fails...


Reply

4 Posts   1856 Views

Avatar
henrik

6 November 2007 at 11:41am (Last edited: 6 November 2007 11:42am), 18 Posts

When trying to access mysite.se/admin I'm redirected to:

Fatal error: Call to undefined method stdClass::Children() in /hsphere/local/home/skraddaren28/brfskraddaren.se/sapphire/core/control/
ContentController.php on line 127

What does this mean?
To access the CMS I have to register through the forum log in.

Avatar
henrik

6 November 2007 at 12:10pm (Last edited: 6 November 2007 1:02pm), 18 Posts

Found out that this happens if a page isn't namned the same way in draft and published site!

Avatar
mseifert

26 November 2007 at 11:01am (Last edited: 26 November 2007 10:25pm), Community Member, 4 Posts

Hi Henrik

Did you manage to get your's working? I have the same problem, but cannot get it fixed. I have compared records in SiteTree and SiteTree_Live (I assume this is where you found the difference), but they are identical as far as URLSegment, Title and MenuTitle.

Any help would be greatly appreciated.

// Morten

Avatar
mseifert

5 December 2007 at 11:09am Community Member, 4 Posts

Hi,

I upgraded to version 2.2.0 and it fixed the problem. Still have not figured out what the problem was.

// Morten