Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Newsletter Subscription form


Reply


21 Posts   22682 Views

Avatar
Big Al

Community Member, 6 Posts

29 December 2007 at 6:13am

Does anyone have a working Newsletter subscription form?

Avatar
Big Al

Community Member, 6 Posts

3 January 2008 at 2:53am

New question about the Newsletter module.

When I send to the list it gets to about 60 of 420 and stops with an error. Is this module memory intensive?

Al

Avatar
Big Al

Community Member, 6 Posts

10 January 2008 at 10:21am

Have newsletter issues with the form and with sending to a 500 member list been resolved?

Is it in the nightly builds?

I am having to use a separate newsletter application and would like to get this all under one roof.

Al

Avatar
cleve

Community Member, 6 Posts

7 February 2008 at 4:52am

Has anyone got any examples of code that we can use to recreate the broken subscription form in the cms?

Avatar
Sam

Administrator, 685 Posts

7 February 2008 at 4:10pm

This has been fixed in the development version and the fix will be available in 2.2.2.

Avatar
maxlamenace

Community Member, 3 Posts

26 February 2008 at 11:26am

Same problem ...

Avatar
psusd

Community Member, 9 Posts

13 March 2008 at 2:29pm

Edited: 13/03/2008 2:55pm

Yes, it's the same problem in that the 2.2.2.rc1 version still doesn't actually work for newsletters. But it's now different behavior. Now you can get the fields to show in a form and everything appears to work from the user's POV. But the emails are never actually entered into the database for the list. It seems to do 'something', as fields start appearing under List Members in the admin, but they are all blank.

Further, the Import Emails function doesn't work either. It works fine up to showing me the fields, with the emails that it will import, but after I click Confirm, the ajax area goes blank and nothing is done. I haven't seen any errors pop up in any of the logs for anything related to that. So I don't know why it would work for showing me the emails in confirmation and not work for actually putting them into the database. I haven't had a chance to look deeply into the code yet to see if I could find the issue, but thought I'd give the devs a heads up.

Avatar
SirSpammenot

Community Member, 9 Posts

14 March 2008 at 5:34pm

Edited: 14/03/2008 5:35pm

Further, the Import Emails function doesn't work either. It works fine up to showing me the fields, with the emails that it will import, but after I click Confirm, the ajax area goes blank and nothing is done.

psusd: I just discovered the same issue (v2.2.1), after confirm... no inserts. Out of curiosity-
How does your csv use quotes?
1) "text1","text2","email@domain.not"
2) text1,text2,email@domain.not
3) 'text1','text2','email@domain.not'

I know the importer works with 2 (because the list displays properly and lets me match fields), but the insert doesn't. Wild guess but maybe we just need to define the CSV format more precisely? Looking into the code over the weekend...