Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Can't Install Silverstripe on Godaddy Linux Hosting


Go to End
Reply


11 Posts   43521 Views

Avatar
Peter Prins

Community Member, 8 Posts

28 November 2007 at 1:55pm

HI, I Can't Install Silverstripe v2.2.0-rc3 on a Godaddy Linux Hosting Account even though mod rewrite is enabled (I have Drupal running with mod rewrite on this same hosting account) the installer claims it isn't. Any suggestions?

This is the .htaccess file SilverStripe writes...

### SILVERSTRIPE START ###
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

This is what I am seeing during the install...

========== STEP 1 ===================
[ http://www.peterprins.biz/install.php ]

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...
# Checking mod_rewrite works
# ERROR: mod_rewrite not working, redirecting to mod_rewrite test page
I will now try and direct you to rewritetest to troubleshoot mod_rewrite

========== STEP 2 ===================
[ http://www.peterprins.biz/rewritetest.php ]

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

========== STEP 3 ===================
[ http://www.peterprins.biz/rewritetest.php?force=1 ]

Forced continue, attempting to redirect to home/successfullyinstalled.

========== STEP 4 ===================
[ http://www.peterprins.biz/home/check-php.php ]

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
* This problem can sometimes be caused by disabling or refusing to accept cookies.

Avatar
alfa

Community Member, 20 Posts

29 November 2007 at 11:04am

Edited: 29/11/2007 11:47am

Same here,

I've tried in two different hosting accounts, one in UK and another in the USA. Both accounts have mod_rewrite enabled and it shows the same error message like yours.

Hope it will be solved soon...

EDIT:

OK, don't know how but trying again over and over on the USA hosting now works everything, but, on the UK hosting (in which im interested) seems to dont work, now it says after installation that can't find file /sapphire/main.php when it is uploaded.. :??

I'll keep trying and hope that the guys on the hosting will help...

Avatar
norova

Community Member, 1 Post

29 November 2007 at 2:05pm

Hello! I had this same exact problem (with a USA server) just a few minutes ago when trying to install SilverStripe. What I did was add a line at the top of the .htaccess file in my SilverStripe folder that says "RewriteEngine on" (Be sure this is above the line that says "### SILVERSTRIPE START ###")

Add that line, wait for about 20-30 minutes and try to install again. This should work. :)

Avatar
alfa

Community Member, 20 Posts

30 November 2007 at 12:56am

Hi there!

This is the solution to my problem, hope it will be usefull for other people with same problem, i'll copy-paste the email from the supporting staff:

" For some reason the file was being wrtten without any leading (RewriteRule .* /sapphire/ ) slashes, this has now been correct for you.
We have copied your .htaccess files below in the case you run into the same problem again:

### SILVERSTRIPE START ###
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ### "

So, try this if you have the same problem as me ^^

Avatar
Peter Prins

Community Member, 8 Posts

2 December 2007 at 12:06pm

I got things working two ways by editing .htaccess either by adding

RewriteBase /

or by adding a / in front of sapphire

RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]

BUT now I have a different problem... dun dun dun...

500 Internal Server Errors

These seem to be happening with ever other refresh of the same page, weird I know, check it for yourself...

Go to http://www.peterprins.biz/ if it shows the page click refresh or click on home and viola 500 Internal Server Error now click refresh and the page is back.

Now click different links in succession About, Contact, Home then About, Contact and no 500 error... but now click on Contact again and bam 500 Internal Server Error

Avatar
alfa

Community Member, 20 Posts

2 December 2007 at 10:28pm

huh

When i check it everything works fine.. probably was error of the servers which is now solved..i dont think that error has to do something with you, most likely it's godaddy's hosting problems.

Cheers

Avatar
luca3003

3 Posts

2 December 2007 at 11:41pm

Hi,
I tried following all of your suggestions but without success.

the website address is http://eurformrfs.ilbello.com

this is my .htaccess file content

### SILVERSTRIPE START ###
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

I hope someone can help me, maybe via chat or skype (look for luca3003).

thank you very much.

Avatar
sonictruth

Community Member, 3 Posts

1 February 2008 at 3:52am

If you have the "INTERNAL SERVER ERROR" problem when you refresh and you're using firefox with SilverStripe at godaddy
comment the line:
//header("Last-Modified: " . self::gmt_date(self::$modification_date));
in sapphire/core/HTTP.php

When this line is enabled the next request from firefox will be with If-Modified-Since header.
This seems to mess up godaddy... don't know why yet.

Go to Top