Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Fatal Error... i'm clueless


Reply

2 Posts   1134 Views

Avatar
grfxmonkey

29 November 2007 at 4:51am Community Member, 1 Post

Forgive me for my cluelessness, but i had this error message when i tried to install. can anyone tell me what i might be doing wrong?

Fatal error: Class 'RequiredFields' not found in /home/grfxmon/public_html/testing2/silverstripe-v2.1.1/sapphire/forms/ComplexRequiredFields.php on line 7

Avatar
mr_lars

29 November 2007 at 5:50am (Last edited: 29 November 2007 5:53am), Community Member, 1 Post

fatal error for me too...
the previous versione worked flawlessly

# Building database schema...

Fatal error: DATABASE ERROR: Couldn't run query: CREATE TABLE `UserDefinedForm` ( ID int(11) not null auto_increment, `EmailTo` varchar(50) character set utf8 collate utf8_general_ci, `EmailOnSubmit` tinyint(1) unsigned not null default '0', `SubmitButtonText` varchar(50) character set utf8 collate utf8_general_ci, `OnCompleteMessage` mediumtext character set utf8 collate utf8_general_ci, fulltext `SearchFields` (Title,MenuTitle,Content,MetaTitle,MetaDescription,MetaKeywords), fulltext `TitleSearchFields` (Title), primary key (ID) ) TYPE=MyISAM | Key column 'Title' doesn't exist in table in xxx.xxx/s/sapphire/core/model/Database.php on line 397

I'm re-uploading in case something went wrong