Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Login fails


Reply


2 Posts   1038 Views

Avatar
mseifert

Community Member, 4 Posts

29 November 2007 at 8:40am

I have created my site and everyting looks great. However, after pressing the "Logout" link, I cannot log into the admin site again. SS gives the following error:

Fatal error: Call to undefined method stdClass::Children() in /usr/home/n92142/public_html/sapphire/core/control/ContentController.php on line 128

When accessing the url http://mysite.com/admin (it then redirects to http://www.sqltablet.com/Security/login and displays the error).

There is a different thread in here whih talks about the same problem, but there the issue was caused by SiteTree and SiteTree_Live not being in sync (not sure why that should be a problem).

I am using version 2.1.1.

I have a different site using SS 2.1.1 as well and I do not have problem at that site - they are hosted on he same server (hosting compay).

I hope someone can help; understanding that you all have been really busy with the new release.

// Morten

Avatar
mseifert

Community Member, 4 Posts

5 December 2007 at 11:09am

Hi,

I upgraded to version 2.2.0 and it fixed the problem. Still have not figured out what the problem was.

// Morten