Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Major problem with upgrade 2.2


Reply


4 Posts   1202 Views

Avatar
Fuzz10

Community Member, 787 Posts

30 November 2007 at 3:47am

Edited: 30/11/2007 4:46am

db/build refuses to finish...

#FATAL ERROR: DATABASE ERROR: Couldn't run query: ALTER TABLE `Page` ADD fulltext `SearchFields` (Title,MenuTitle,Content,MetaTitle,MetaDescription,MetaKeywords), ADD fulltext `TitleSearchFields` (Title) | Key column 'Title' doesn't exist in table

At line 397 in /var/www/sites/www.xxxxx.nl/htdocs/sapphire/core/model/Database.php

Update 1:
I can't figure out why it uses these column names they don't even exist in that table.....

Update 2:
This is really weird. I had to copy the database to our local development server. Upgrade the database through the db/build script and then copy the database back tot the live server. All the website-code is the same on both machines. If I run the db/build script now (on the live server) , it doesn't want to upgrade anything ... which is correct. I hope this will not happen again on the next big upgrade , took a lot of time...

Avatar
StuartPreston

Community Member, 1 Post

30 November 2007 at 10:16am

Just to add that I receive the same error on a clean installation:

----
Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating '.htaccess' file...
Building database schema...
Fatal error: DATABASE ERROR: Couldn't run query: CREATE TABLE `UserDefinedForm` ( ID int(11) not null auto_increment, `EmailTo` varchar(50) character set utf8 collate utf8_general_ci, `EmailOnSubmit` tinyint(1) unsigned not null default '0', `SubmitButtonText` varchar(50) character set utf8 collate utf8_general_ci, `OnCompleteMessage` mediumtext character set utf8 collate utf8_general_ci, fulltext `SearchFields` (Title,MenuTitle,Content,MetaTitle,MetaDescription,MetaKeywords), fulltext `TitleSearchFields` (Title), primary key (ID) ) TYPE=MyISAM | Key column 'Title' doesn't exist in table in /var/www/vhosts/MYDOMAIN/httpdocs/sapphire/core/model/Database.php on line 397
----

I'm running Apache2/PHP 5.1.2/MySQL 5.0.22 (14.12)

Any advice appreciated.

Avatar
Sigurd

Forum Moderator, 628 Posts

4 December 2007 at 2:06pm

This may be PHP 5.1.2; we have found some people to have issues with PHP 5.1.2 that go away with PHP 5.1.6.

We recommend PHP 5.2.x

Note that it is often PHP itself which has bugs...

Avatar
Fuzz10

Community Member, 787 Posts

5 December 2007 at 2:29am

Thanks Sig,

That might well be the case (we are running 1.2) ..

I'll have the version upgraded ASAP. ;-)